Skip to main content
Topic: ElkArte 1.1 Release Candidate 1 - Release announcement (Read 2030 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

ElkArte 1.1 Release Candidate 1 - Release announcement

The ElkArte Community is pleased to announce the first ElkArte 1.1 Release Candidate is now available. The release candidate is usually the last development step before release a stable version, made available to allow a final round of testing on what will be the first major version of ElkArte, though it's still considered a development version and as such is not recommended for production use.

In order to help us release ElkArte, anyone using the new version, is encouraged to report bugs, issues or errors at our GitHub Issue Tracker.

If you are not comfortable reporting bugs through the formal bug reporting system, you can simply report your issues to our user community at ElkArte.net.

We look forward to receiving your feedback on this release candidate of ElkArte!


Download the package from:
https://github.com/elkarte/Elkarte/releases/tag/v1.1.0-RC.1

Some recommendations
Starting from 1.1 the install and upgrade packages have been unified, so the same package will be used for both install a new forum and upgrade an existing previous version of ElkArte (e.g. 1.0).
As usual, do not try to upgrade a live forum, as stated earlier this is a development version, so you should use it for testing only. Of course if you are mad brave enough to use it live... well pay attention it can have bugs. The amount  is currently not sure.

Some instruction
  • Upgrading from 1.0: in this case, overwrite all the files with those in the package of the release, run install/upgrade.php and enjoy the new version.
  • Updating from previous beta: unzip the package, overwrite all the files of your testing forum with the new ones, delete the install directory, and enjoy the new version.
Bugs creator.
Features destroyer.
Template killer.

Re: ElkArte 1.1 Release Candidate 1 - Release announcement

Reply #1
Wow! I will skip the 1.0.10 update problem and install this one.  :D

Need to work on the translation now. Thanks!  >:(  ;)

Re: ElkArte 1.1 Release Candidate 1 - Release announcement

Reply #2
If you want my suggestion, do the 1.0.10. ;)
Then you have time to work on that.
Bugs creator.
Features destroyer.
Template killer.

Re: ElkArte 1.1 Release Candidate 1 - Release announcement

Reply #3
Wow! Well done guys. Crazy to see what you guys have accomplished here over the last couple of years.
Success is not the result of spontaneous combustion, you must set yourself on fire!

Re: ElkArte 1.1 Release Candidate 1 - Release announcement

Reply #4
Great job.

Re: ElkArte 1.1 Release Candidate 1 - Release announcement

Reply #5
Congratulations on the RC.

I might throw it on local, then grumble about all the new-fangled stuffz. :D
Master of Expletives: Now with improved family f@&king friendliness! :D

Sources code: making easy front end changes difficult since 1873. :P

Re: ElkArte 1.1 Release Candidate 1 - Release announcement

Reply #6
Just upgraded my test site ;)
I unistalled all the addons, uploaded the files via ftp, and the installer started. I had an error (something that I should use the upgrade from 1.0, I don't remember exactly) after I was not able to login, a database error. I uploaded again the install folder and run upgrade.php, seems fine now ;)

This was an easy task, now I should test every addon I have on my 1.0.10 version + language files  :'(
sorry for my bad english

Re: ElkArte 1.1 Release Candidate 1 - Release announcement

Reply #7
Next time, if you can, please take note of the exact error, I've never seen it and it would be nice to track it down. :)
Bugs creator.
Features destroyer.
Template killer.


 

Re: ElkArte 1.1 Release Candidate 1 - Release announcement

Reply #9
very cool .. Thanks !
“The problem is not the problem. The problem is your attitude about the problem. Do you understand?” – Jack Sparrow