Skip to main content
Topic: Add version compatibility to addons site (Read 398 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Add version compatibility to addons site

What do you think about the idea to add a field with elkarte version compatibility in addons website? Right now there are some add-ons compatible with 1.1 but you need to check the topic to see if they are compatible or not.
sorry for my bad english

Re: Add version compatibility to addons site

Reply #1
Yes, I prefer to use some other option instead of "Requires: ElkArte 1.0 (+)", since that doesn't tells you if it's compatible with 1.1 in this case.

Re: Add version compatibility to addons site

Reply #2
Most of the addons are in this forum addon board and all users have to do is - ask in the relevant addon topic.

Good interactions as between addon users and authors will help this forum to grow as well as giving good input to other readers.

Re: Add version compatibility to addons site

Reply #3
The addon site will show what the author adds to the "elkversion" field in the yaml file  (the file you commit to the addon site to publish the release).

So if that field says 1.0-1.1 the site shows ........ Requires ElkArte 1.0-1.1 (+)

So starting here, what improvement would you like to see to help?

“The problem is not the problem. The problem is your attitude about the problem. Do you understand?” – Jack Sparrow

Re: Add version compatibility to addons site

Reply #4
So starting here, what improvement would you like to see to help?
maybe a pair of glasses  8) my mistake, scuse me, I didn't notice that field  :-[ :-[
sorry for my bad english

Re: Add version compatibility to addons site

Reply #5
Something like this?

Elk Version    ElkArte 1.0 (+)
Requires    ElkArte 1.0 (+) Variant only, other addon, Some 3rd party Account and/or software/connection
Category    Administration

Some of the addons have become a included feature.
Be nice if that was some how noted (& which version).

PERHAPS a - sign at the front, to indicate use the addon below version#
-ElkArte 1.0 (+)
OR
ElkArte -1.0 (+)

Re: Add version compatibility to addons site

Reply #6
Yes, I prefer to use some other option instead of "Requires: ElkArte 1.0 (+)", since that doesn't tells you if it's compatible with 1.1 in this case.

This.  There is at least one hooks only addon which will whitescreen 1.1.  The only fixes are manually removing hooks from the DB or restoring a DB backup.  You're right, every admin should make a backup prior, every admin should study up how to do this, every admin should use hosting where they have top level access.  Reality is often far different.  A little info inclusion could avoid much troubles for someone.  And it looks professional!   ;)

Re: Add version compatibility to addons site

Reply #7
And 1.1 should have been backward compatible, but it's not. :P
Bugs creator.
Features destroyer.
Template killer.

Re: Add version compatibility to addons site

Reply #8
BTW: if you know an addon that doesn't work in 1.1, feel free to post in the topic, it may be worth fixing it. ;D
Bugs creator.
Features destroyer.
Template killer.

 

Re: Add version compatibility to addons site

Reply #9
Simple Portal was the first add-on I tried to install,but had errors, I will post into the topic of sp
sorry for my bad english

Re: Add version compatibility to addons site

Reply #10
Yes, I prefer to use some other option instead of "Requires: ElkArte 1.0 (+)", since that doesn't tells you if it's compatible with 1.1 in this case.

This.  There is at least one hooks only addon which will whitescreen 1.1.  The only fixes are manually removing hooks from the DB or restoring a DB backup.
You can also delete the addon's files. Its calls will silently be ignored then :D (Only for those without source edits!)

Re: Add version compatibility to addons site

Reply #11
BTW: if you know an addon that doesn't work in 1.1, feel free to post in the topic, it may be worth fixing it. ;D


Done, it's certainly worth a shot!



You can also delete the addon's files. Its calls will silently be ignored then :D (Only for those without source edits!)

Good to know.  Works perfectly!  That would be great in the docs....;)

Re: Add version compatibility to addons site

Reply #12
Much easier than editing the db :)

Re: Add version compatibility to addons site

Reply #13
Hope no one minds, if I expand on the suggestion,

All the major addon info needs to be available, AS WELL, on the addon info page.

Seems currently, this type of info can only be seen from the Addons Home page listing.
For example, click on a "mod" from the recent updated display box.
It entirely misses pertinent info like Author, version, etc..

Of course need to keep the initial listing and search ability of the home page.
That means need to repeat the basic design info to  individual Addon page.




Re: Add version compatibility to addons site

Reply #14
Thats a valid point ... right now the details does not show the version compatibility details and it should.  I opened the issue so its tracked.  
“The problem is not the problem. The problem is your attitude about the problem. Do you understand?” – Jack Sparrow