Skip to main content
Topic: Is ElkArte 1.1.3 running with PHP 7.2.1 ? (Read 350 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Is ElkArte 1.1.3 running with PHP 7.2.1 ?

Hello,
I want to switch from PHP 5.5.38 to a 7er version in the next few days.
My hoster offers these:

PHP 7.0.25
PHP 7.1.11
PHP 7.2.1

Is it okay if I take the 7.2.1 ? Is ElkArte 1.1.3 running with it without problems?
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Is ElkArte 1.1.3 running with PHP 7.2.1 ?

Reply #1
Currently running 1.1.3 on 7.2.4.   8)

Re: Is ElkArte 1.1.3 running with PHP 7.2.1 ?

Reply #2
Ah, okay. That sounds good. :)
Thank you!
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Is ElkArte 1.1.3 running with PHP 7.2.1 ?

Reply #3
I'm also running a test forum on 7.2.4 ;)
sorry for my bad english

Re: Is ElkArte 1.1.3 running with PHP 7.2.1 ?

Reply #4
That sounds good too. :)
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Is ElkArte 1.1.3 running with PHP 7.2.1 ?

Reply #5
I think with 7.2 there may be some edge cases still open, but I lost a bit track...
Bugs creator.
Features destroyer.
Template killer.


Re: Is ElkArte 1.1.3 running with PHP 7.2.1 ?

Reply #7
Hi,
i was on 7.0 and i just pass to 7.2 few minutes ago to test : with very quick test, "everything" seems to work fine.
Philippe

EDIT1
In fact it is 7.2.4 and after hours it is still fine !
philippe

EDIT2
I just get this error in Files attachments settings
Code: [Select]
count(): Parameter must be an array or an object that implements Countable
if i go back to 7.0 no more error !
7.2.4 is not 7.2.1 but you can check check this page. No erors on the other pages at this time and i think i have tried all the pages since this afternoon.
Philippe

Re: Is ElkArte 1.1.3 running with PHP 7.2.1 ?

Reply #8
Oh yes, that is the one I was referring to.
It's in the PM area, I think I already pushed a fix for 1.1.4, but I have to find where it is.
Bugs creator.
Features destroyer.
Template killer.