Skip to main content
Topic: [ADDON] Social Login and Register (Read 3742 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: [ADDON] Social Login and Register

Reply #15
It should require you to fill any required (standard or custom) profile fields .... however it does not try to "match" any of those with info that it gets from the social network (like it will with email, member name, avatar etc)
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: [ADDON] Social Login and Register

Reply #16
@badmonkey‍ I updated the package in the first post, it has the font awesome "on" setting for 1.1, so give that a try  :D
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: [ADDON] Social Login and Register

Reply #17
It should require you to fill any required (standard or custom) profile fields ....
That's perfect, most forums works this way  8)
sorry for my bad english

Re: [ADDON] Social Login and Register

Reply #18
Woohoo!  That works!  Thanks @Spuds

Got FB setup and working.  Giggle has an error when trying link accounts.

Code: [Select]
400. That’s an error.

Error: redirect_uri_mismatch

The redirect URI in the request, http://www.awaycamping.com/sources/ext/hybridauth?hauth.done=Google, does not match the ones authorized for the OAuth client. Visit https://console.developers.google.com/apis/credentials/oauthclient/332790426228-2snqk0f0fc6ofhke81ebkr8ktca15f95.apps.googleusercontent.com?project=332790426228 to update the authorized redirect URIs.


What's wrong here?  Thanks!

Re: [ADDON] Social Login and Register

Reply #19
Changing the redirect uri to

Code: [Select]
http://www.awaycamping.com/sources/ext/endpoint?hauth.done=Google


got past the uri error to the permissions page.  Click Allow, now a 500 error.   :(

Code: [Select]
2017/03/29 19:33:03 [error] 4323#0: *4933836 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Call to undefined function fatal_error() in /var/www/clients/.../web2/web/sources/controllers/Extauth.controller.php on line 243" while reading response header from upstream, client: 137.118....., server: awaycamping.com, request: "GET /index.php?action=extauth;provider=google;sa=auth;member=1;s2d9a0TC4vW=1071ps2d9a........KGh3oVMX HTTP/1.1", upstream: "fastcgi://127.0.0.1:9011", host: "www.awaycamping.com"


Re: [ADDON] Social Login and Register

Reply #20
Nevermind.  Back to the 400 error.  Not sure what in the world.

Re: [ADDON] Social Login and Register

Reply #21
I think one of those errors is due to 1.1 vs 1.0.
Woohoo!  That works!  Thanks @Spuds

Got FB setup and working.  Giggle has an error when trying link accounts.

Code: [Select]
400. That’s an error.

Error: redirect_uri_mismatch

The redirect URI in the request, http://www.awaycamping.com/sources/ext/hybridauth?hauth.done=Google, does not match the ones authorized for the OAuth client. Visit https://console.developers.google.com/apis/credentials/oauthclient/332790426228-2snqk0f0fc6ofhke81ebkr8ktca15f95.apps.googleusercontent.com?project=332790426228 to update the authorized redirect URIs.


What's wrong here?  Thanks!
Double check that the redirect URL you entered in the Google API console is correct. 


Some of the other errors (the fatal error error) is due to 1.0 vs 1.1 ...
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: [ADDON] Social Login and Register

Reply #22
Thanks spuds.  *Thought* I had entered that as a redirect addy.  Apparently not!  ;D 

The 500 error is gone when attempting to connect.  Permissions are granted, redirected back to the site, but the button still says Connect Using Google. 

There is a 500 error if attempting to register using Google. 

Re: [ADDON] Social Login and Register

Reply #23
I'm going to guess the 500 error is some other 1.1 issue ... I'll take a look 
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: [ADDON] Social Login and Register

Reply #24
Updated package for ElkArte 1.1
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: [ADDON] Social Login and Register

Reply #25
Is anybody using this mod successfully for facebook? I'm constantly running into errors and fb's docs are not helpful.

Currently I'm having these issues:

  • Using the app myself I'm able to login but facebook warns me that some of the app's permissions are not approved yet. It is asking for access to my personal profile, description and email. It happens only the first time I use it to log in my forum.
  • If another user tries to use the facebook login button on my forum, facebook won't prompt any warn (it asks only profile and email, NOT description, though). But ElkArte will: "Unable to verify referring URL: https://www.facebook.com/. Please try again". But guess what? That user will be able to use the feature nevertheless.

I'm using Elk 1.0.10 (waiting for Spuds' SimplePortal mod to be complete :) ) and SP Beta 2. I still have to pass the fb app review 'cause it must be perfectly functional, perfectly this, perfectly that.

Thank you ;)

Re: [ADDON] Social Login and Register

Reply #26
Last time I tested , I think it was working, but I can't remember whether I was testing it in EA 1.0 or 1.1.

About SP, I think it is working too.

Re: [ADDON] Social Login and Register

Reply #27
Does this also store the email adress of the user that logs in e.g. via Facebook ?

I want to have all valid email adresses of all users on my forum, so I can send them from time to time
some newsletters, without getting too many bounced emails due to faked email adresses..or just no email adresses
if they login just via Facebook ?

Re: [ADDON] Social Login and Register

Reply #28
Sorry for the late reply ... yes it gets the Email address form FB or whatever login providers you use ... It will be the email address they signed up with for FB or Google or Yahoo etc ...
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.