ElkArte Community

Elk Development => Bug Reports => Exterminated Bugs => Topic started by: badmonkey on June 28, 2018, 09:56:02 pm

Title: IE11 cannot accept privacy policy 1.1.4
Post by: badmonkey on June 28, 2018, 09:56:02 pm
IE11 fails to load the page for accepting the privacy policy.  The browser acts as if loading but never does.  Once the user accepts the privacy policy in a different browser, they can successfully login using IE11 again.  
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: lurkalot on June 28, 2018, 10:01:57 pm
At last, someone with the exact same problem, https://www.elkarte.net/community/index.php?topic=5284.0

You'll find it's the same in Edge too. Or at least it was for me.
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: Spuds on June 29, 2018, 02:09:37 am
Strange ... I wonder if it does not like the refresh vs using a location header?  I'm not sure why refresh was used but @emanuele should know.
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: badmonkey on July 02, 2018, 08:23:46 pm
This is demonstrated to be a significant issue.  One user could not login using FF either until he cleared all browsing and cookie data, even though the first attempt was in IE.  

Full disclosure:  nginx 1.14.0, php 7.2.7, mariadb 10.2.16. 
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: emanuele on July 02, 2018, 09:56:48 pm
hmm... well, try without refresh I guess.
Code: [Select]
redirectexit('action=register;sa=agreement', true);
to:
Code: [Select]
redirectexit('action=register;sa=agreement');
and:
Code: [Select]
redirectexit('action=register;sa=privacypol', true);
to:
Code: [Select]
redirectexit('action=register;sa=privacypol');
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: badmonkey on July 03, 2018, 02:26:21 am
What file is that?  register.controller.php? 
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: ahrasis on July 03, 2018, 08:33:25 am
Full disclosure:  nginx 1.14.0, php 7.2.7, mariadb 10.2.16.
Good latest setup you have there[1]@badmonkey though I don't think IE11 error is related to it in anyway.
Off topic: Mariadb has been 10.3 for quite some times now so you might want to upgrade. ;D
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: Spuds on July 03, 2018, 01:53:57 pm
What file is that?  register.controller.php?
Both lines are in Load.php
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: badmonkey on July 03, 2018, 02:25:09 pm
hmm... well, try without refresh I guess.
Code: [Select]
redirectexit('action=register;sa=agreement', true);
to:
Code: [Select]
redirectexit('action=register;sa=agreement');
and:
Code: [Select]
redirectexit('action=register;sa=privacypol', true);
to:
Code: [Select]
redirectexit('action=register;sa=privacypol');
 
 That seems to work!  Thanks eman!   8)





Full disclosure:  nginx 1.14.0, php 7.2.7, mariadb 10.2.16.
  Good latest setup you have there[1]@badmonkey though I don't think IE11 error is related to it in anyway.
 
 Thanks!  10.3 has been on the radar.  Admittedly I've been to lazy to set it up the repo.   :-X  Agreed, though in the interest of being thorough.... :D




What file is that?  register.controller.php?
  Both lines are in Load.php
 
 Ah yes!  Duh!  lol!  Thanks spuds! 
Off topic: Mariadb has been 10.3 for quite some times now so you might want to upgrade. ;D
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: emanuele on July 03, 2018, 11:55:08 pm
oops... I thought I posted the file name... :-[
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: emanuele on July 04, 2018, 10:35:48 am
I think we can plan a quick release to fix this specific bug that is quite important?
A week or two maximum?
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: Spuds on July 04, 2018, 03:59:48 pm
/me goes looking for more bugs :D
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: badmonkey on July 04, 2018, 04:51:43 pm
/me goes looking for more bugs :D
 
 





/me is available to write some for you.


;D
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: emanuele on July 04, 2018, 05:43:26 pm
/me is the only one allowed to write bugs!
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: kode54 on July 09, 2018, 03:13:49 am
I'm so glad I don't have the privacy agreement feature enabled on our forum yet, then.

Full disclosure:  nginx 1.14.0, php 7.2.7, mariadb 10.2.16.

Oh, and you think your versions are old?

Full disclosure: nginx-openresty 1.13.6.2, php 7.0.30, mariadb 5.5.56. This is what I got from running CentOS 7, with EPEL, Webtatic, and two OpenResty repositories.
Title: Re: IE11 cannot accept privacy policy 1.1.4
Post by: badmonkey on July 09, 2018, 04:14:36 am
I'm so glad I don't have the privacy agreement feature enabled on our forum yet, then.

Full disclosure:  nginx 1.14.0, php 7.2.7, mariadb 10.2.16.
  
Oh, and you think your versions are old?

 
 Not at all! Just trying to include any info that could have been relevant at the time, since the cause was not yet known. ;)