ElkArte Community

Extending Elk => Custom Themes => Topic started by: Spuds on April 26, 2016, 09:54:10 pm

Title: [Theme] Lazy Day
Post by: Spuds on April 26, 2016, 09:54:10 pm
Been a bit since I put a theme together, so here is a new one.   Called it lazy day since  that's how I feel .. always  :P

A light theme with shades of grey and blue, larger fonts and more contrast in text in some areas. The board index layout has changed for a cleaner look. The message index is redone to show the avatar first, and move topic page navigation to a single area. The topic display has an updated poster area where some items that were normally hidden in the drop down have been exposed. Has a slider quick login bar and a expanding search menu to jazz things up a bit.

Few other things here and there, I'm sure there are bugs, but

http://themes.ElkArte.net/creative/Lazy-Day.html
Title: Re: [Theme] Lazy Day
Post by: meetdilip on April 26, 2016, 10:20:58 pm
Nice work. Thanks :)
Title: Re: [Theme] Lazy Day
Post by: Eliana Tamerin on April 26, 2016, 10:45:55 pm
I like it. It's clean and simple without being too, ahem, green.
Title: Re: [Theme] Lazy Day
Post by: emanuele on April 26, 2016, 11:41:11 pm
Green is never enough! :P
Title: Re: [Theme] Lazy Day
Post by: Eliana Tamerin on April 27, 2016, 12:03:07 am
Green is never enough! :P

If I puke on your shoes, will you agree that you've been wrong all along?
Title: Re: [Theme] Lazy Day
Post by: ahrasis on April 27, 2016, 05:40:27 am
I like the attachment (is it ILA or something?). By the way, can we add like to each attachment, somehow?
Title: Re: [Theme] Lazy Day
Post by: Jorin on April 27, 2016, 07:31:28 am
Looks good! Know you have to change the buttons a bit too.  ;)
Title: Re: [Theme] Lazy Day
Post by: Jason on April 28, 2016, 03:07:40 pm
Themes looks nice, will try working with the theme.
Title: Re: [Theme] Lazy Day
Post by: Spuds on April 28, 2016, 03:52:56 pm
Looks good! Know you have to change the buttons a bit too.  ;)
Which ones in particular, and do you have suggestions  O:-)
Title: Re: [Theme] Lazy Day
Post by: Jorin on April 29, 2016, 07:30:33 am
All the buttons.  :D

Maybe give them the same border as the author info in the post screenshot has. They don't really fit to the rest, IMO.  O:-)
Title: Re: [Theme] Lazy Day
Post by: Jason on May 08, 2016, 04:38:32 pm
The packing need slight modification, when installed, all files goes to

\themes\Elk_Theme_LazyDay-master\Elk_Theme_LazyDay-master

instead of

\themes\Elk_Theme_LazyDay-master\

So the theme doesn't work till you move all the files to the second path.
Title: Re: [Theme] Lazy Day
Post by: Spuds on May 08, 2016, 06:47:14 pm
Thanks for letting me know, I'll get it fixed.
Title: Re: [Theme] Lazy Day
Post by: Jason on May 15, 2016, 10:02:11 am
@Spuds How to change the color of mobile icon, it looks little dull in my mobile. So i want it little bright
Title: Re: [Theme] Lazy Day
Post by: Spuds on May 15, 2016, 10:11:50 pm
in the index_grey.css file you will find a section that says
Code: [Select]
	[data-icon]:before {
In there will be a color: #xxxxxx; change that to say #CCC; or #DDD;
Title: Re: [Theme] Lazy Day
Post by: Jason on May 16, 2016, 01:22:34 pm
@Spuds Thanks a lot, finally figured the settings. And now it is good.
Title: Re: [Theme] Lazy Day
Post by: meetdilip on May 17, 2016, 06:58:52 pm
@Spuds , which font did you use on this theme ?
Title: Re: [Theme] Lazy Day
Post by: Jason on May 17, 2016, 07:15:53 pm
Where is fa icons present, i want to change few fa icons in post section.

And in the footer i need a facebook fa icon, i tried this http://www.elkarte.net/community/index.php?topic=2386.msg15693#msg15693 but it shows an error
Title: Re: [Theme] Lazy Day
Post by: Spuds on May 17, 2016, 08:12:07 pm
@Spuds , which font did you use on this theme ?
This one uses google Open Sans webfonts, if you look in its index.template you will find
Code: [Select]
<link href="https://fonts.googleapis.com/css?family=Open+Sans:400,400italic,600,600italic,700,700italic" rel="stylesheet" type="text/css">';
which are the standard, demi-bold and bold fonts + italic variations.

Where is fa icons present, i want to change few fa icons in post section.

And in the footer i need a facebook fa icon, i tried this http://www.ElkArte.net/community/index.php?topic=2386.msg15693#msg15693 but it shows an error
You will have to look in the CSS, search for "font-family: 'FontAwesome';" those will have a content: tag like content: "\f05a"; you will find the content code for the icons from font awesomes website.

I've fix a few things over the last couple of days on this theme and pushed a couple of updates as well.
Title: Re: [Theme] Lazy Day
Post by: Jason on May 18, 2016, 06:17:48 pm
@Spuds Thanks, i have modified your theme version slightly and i will post the new look soon :) That's why so many queries :D
Title: Re: [Theme] Lazy Day
Post by: Spuds on May 18, 2016, 07:12:13 pm
Cool ... Its free and open so do what you like with it :D  Looking forward to what you have come up with !
Title: Re: [Theme] Lazy Day
Post by: Jason on May 18, 2016, 07:39:14 pm
Just the preview of my small cosmetic changes

Title: Re: [Theme] Lazy Day
Post by: jakedp on May 18, 2016, 09:49:44 pm
Been a bit since I put a theme together, so here is a new one.   Called it lazy day since  that's how I feel .. always  :P

A light theme with shades of grey and blue, larger fonts and more contrast in text in some areas. The board index layout has changed for a cleaner look. The message index is redone to show the avatar first, and move topic page navigation to a single area. The topic display has an updated poster area where some items that were normally hidden in the drop down have been exposed. Has a slider quick login bar and a expanding search menu to jazz things up a bit.

Few other things here and there, I'm sure there are bugs, but

http://themes.ElkArte.net/creative/Lazy-Day.html

Very well done. That was the kind of theme I was looking for and couldn' t find before modifying Silence.
Title: Re: [Theme] Lazy Day
Post by: kucing on May 18, 2016, 11:27:00 pm
wow, i will try it on my forum @Spuds ! This is similar in color scheme with my current theme but looks better. :)

Edit:

Found problems, in the demo the icons for info and online area pictures (png) but in the demo using font awesome. thus it returns 404 not found. is there any settings for this?

and

maybe there is something wrong, but is there a setting for user profile position in discussion? is not on the left side but on the above. you can see it in my forum.

Edit2:

When I clicked the picture in attachments it's not displayed to bigger size and stays as thumbnail.
Title: Re: [Theme] Lazy Day
Post by: emanuele on May 26, 2016, 03:32:38 pm
/me feels @Spuds is slacking a bit supporting his themes .:P

By chance, do you have the theme live somewhere? Just to avoid having to install another forum for testing the theme.

/me wonders how difficult would be to set up a demo site pulling the packages from the github repo...
Title: Re: [Theme] Lazy Day
Post by: CrimeS on May 26, 2016, 03:50:00 pm
/me wonders how difficult would be to set up a demo site pulling the packages from the github repo...

/me likes this idea very much...
Title: Re: [Theme] Lazy Day
Post by: meetdilip on May 26, 2016, 03:56:49 pm
/me thinks demo site will be awesome
Title: Re: [Theme] Lazy Day
Post by: Spuds on May 26, 2016, 04:17:30 pm
Sorry ... its those darn edits, they don't re-flag a message as unread

I've seen the second issue in the PM area because I forgot to push that template, I'll have to check on the other issues, had not seen those.
Title: Re: [Theme] Lazy Day
Post by: Spuds on May 26, 2016, 06:39:53 pm
Other than the attachment zoom issue, I was not able to reproduce what you are seeing.  Please make sure you have all of the template files for this theme in its theme directory and that they are accessible.
Title: Re: [Theme] Lazy Day
Post by: kucing on May 30, 2016, 01:11:01 am
Other than the attachment zoom issue, I was not able to reproduce what you are seeing.  Please make sure you have all of the template files for this theme in its theme directory and that they are accessible.

thanks @Spuds ! Mostly fixed all issues I found. :)

Edit:

Hi @Spuds , can you point me the example topic with picture attachment? I tried to find it yesterday but didn't find any. :( I want to see how the picture will be displayed when clicked, because it's still too small in my forum. the behavior is different with the default theme.
Title: Re: [Theme] Lazy Day
Post by: Jason on July 07, 2016, 07:22:26 am
I need help in fixing the menu, instead of the drop down menu in Community. I want Community and Other - where the dropdowns should be listed.
Title: Re: [Theme] Lazy Day
Post by: emanuele on July 07, 2016, 01:52:09 pm
So you want to change the text of the button from "Community" to "Community and Other"?
Open your themes/default/languages/english/Addons.english.php and add this string at the end:
Code: [Select]
$txt['community'] = 'Community and Other';
Title: Re: [Theme] Lazy Day
Post by: Jason on July 07, 2016, 02:40:27 pm
@emanuele Sorry that i didn't explained clearly. Instead of Community text having the drop down menus i want another text to have it.

My current scenario, Community (with its dropdown menus), new posts, new replies

What i wanted, Community, new posts, new replies, Misc (with dropdown menus)

(Similar to what we have in Elkarte (Home, Community), i want Home, Misc (with dropdown)
Title: Re: [Theme] Lazy Day
Post by: emanuele on July 07, 2016, 03:07:17 pm
Ahhh... okay, I got it wrong. :P

http://www.elkarte.net/community/index.php?topic=1114.msg7919#msg7919
This addon is the one we are using here, you can install it and then modify to suit your needs, for example if you want the button after "new replies", you could change
Code: [Select]
	$buttons = elk_array_insert($buttons, 'home', array(
'base' => array(
'title' => $txt['home_btn'],
'href' => $parsed['scheme'] . '://' . $parsed['host'] . (!empty($parsed['port']) ? ':' . $parsed['port'] : '') . '/',
'data-icon' => '',
'show' => true,
'action_hook' => true,
),
));
to:
Code: [Select]
	$buttons = elk_array_insert($buttons, 'unreadreplies', array(
'base' => array(
'title' => $txt['home_btn'],
'href' => $parsed['scheme'] . '://' . $parsed['host'] . (!empty($parsed['port']) ? ':' . $parsed['port'] : '') . '/',
'data-icon' => '',
'show' => true,
'action_hook' => true,
),
), 'after');
}
Title: Re: [Theme] Lazy Day
Post by: Jason on July 07, 2016, 03:18:11 pm
Thanks emanuele!.
Title: Re: [Theme] Lazy Day
Post by: Jason on July 23, 2016, 07:19:17 pm
Anyone using this theme? any issues with them?
Title: Re: [Theme] Lazy Day
Post by: Jason on August 03, 2016, 08:11:50 pm
@Spuds I want the color to fade away and only the last child should have the grey color. How to do it?

Title: Re: [Theme] Lazy Day
Post by: ahrasis on August 04, 2016, 03:13:22 am
I think its the linktree after and you should be able to modify for the first child i.e. for home icon.
Title: Re: [Theme] Lazy Day
Post by: Jason on August 06, 2016, 08:25:11 pm
I think its the linktree after and you should be able to modify for the first child i.e. for home icon.

I did try, but instead of the sharp image (>) it goes blunt (|)
=======================================================

By the way i have edited the CSS and have added the files here. Do test it if you want and share your feedback
Title: Re: [Theme] Lazy Day
Post by: ahrasis on August 07, 2016, 01:50:04 am
I have done something to my linktree css as well but that is not properly finished. Currently, I am still playing with multiple php setup. I will look back into this once I have finished / tired of playing with it.
Title: Re: [Theme] Lazy Day
Post by: kucing on August 16, 2016, 12:09:25 pm
I'm reporting a display problem. After updating to 1.0.9 in mobile view there is no rank bar and the member role in the forum.
Title: Re: [Theme] Lazy Day
Post by: Spuds on September 05, 2016, 01:54:23 am
I'm reporting a display problem. After updating to 1.0.9 in mobile view there is no rank bar and the member role in the forum.
I did take a look  at this ... its not specific to 1.0.9.  Those elements being hidden is a result of a media query, not 1.0.9

I did make some media query "tweaks" to improve things a bit, so try out the latest released version on github and see if that improves things for you (of course only do this if you have not done your own edits to the css files)
Title: Re: [Theme] Lazy Day
Post by: kucing on April 27, 2017, 03:48:57 am
I'm reporting a display problem. After updating to 1.0.9 in mobile view there is no rank bar and the member role in the forum.
I did take a look  at this ... its not specific to 1.0.9.  Those elements being hidden is a result of a media query, not 1.0.9

I did make some media query "tweaks" to improve things a bit, so try out the latest released version on github and see if that improves things for you (of course only do this if you have not done your own edits to the css files)

how i missed this reply, updated but it looks like it still missing from my phone (redmi note 3 pro), maybe the phone screen resolution smaller?

-

and the theme still not compatible with patch 1.0.10 or is it safe to ignore?
Title: Re: [Theme] Lazy Day
Post by: kucing on May 01, 2017, 04:08:49 pm
Hi @Spuds I see there are some new commits to LazyDay: https://github.com/Spuds/Elk_Theme_LazyDay/

Should I wait for released package?

Thanks.
Title: Re: [Theme] Lazy Day
Post by: Spuds on May 01, 2017, 05:08:36 pm
I'll get the update out in a couple of days, have one more thing that I may tweak.

If you have not installed 1.0.10, do so and ignore any errors you get when installing that update it in this theme.  When I get the update one you will just overwrite the existing files.
Title: Re: [Theme] Lazy Day
Post by: Raitou on May 23, 2017, 11:45:44 am
Can I ask if you create a dark version of it O wO?
Title: Re: [Theme] Lazy Day
Post by: Jason on April 22, 2018, 11:14:31 am
Any chance an updated version will come out??

@Spuds font awesome is not working, how to fix it?
Title: Re: [Theme] Lazy Day
Post by: Jason on June 16, 2018, 01:36:35 pm
How to rectify this error?

I am trying to use  Lazy Day them in Version 1.1.3, and when i visit the profile i get this error.
Title: Re: [Theme] Lazy Day
Post by: radu81 on June 16, 2018, 02:00:21 pm
This theme is not compatible with elkarte 1.1.x.
Title: Re: [Theme] Lazy Day
Post by: Spuds on June 16, 2018, 02:18:50 pm
Yeah I've been trying to get that one updated for 1.1, attached is as far as I've gotten so far ... Not sure it will fix the bug you see or not (yet).

ETA added newer version below:
Title: Re: [Theme] Lazy Day
Post by: Jason on June 16, 2018, 03:42:12 pm
@Spuds my bad, i should have contacted you first before start working on the theme.  :o

I was working on re-designing the theme in the middle i found the issues.

Now i need to re-work the CSS again... Thanks for the files, it fixed most of the issues. I don't know what else is need to be fixed. I will update this thread if i find a bug.

Title: Re: [Theme] Lazy Day
Post by: Spuds on June 16, 2018, 05:22:55 pm
Thanks ... I've been very slow in getting my themes updated ... some are easy and some like this one are a bit more involved.
Title: Re: [Theme] Lazy Day
Post by: Jason on June 16, 2018, 05:26:24 pm
@Spuds so i can go ahead and start re-designing the theme again? Or is there any updation left?
Title: Re: [Theme] Lazy Day
Post by: Spuds on June 16, 2018, 10:07:45 pm
Let me see what changes 1.1.4 may require and I'll upload a new file, it should then be good to go

ETA attached 1.1.4 tweaks as needed
Title: Re: [Theme] Lazy Day
Post by: Jason on June 17, 2018, 08:18:41 am
@Spuds Thank you so much, that was really quick. I will check and update you!
Title: Re: [Theme] Lazy Day
Post by: TaliaJoy on August 05, 2018, 12:54:30 am
Oh thank you, I just installed ElkArte and this theme and had the same problem, until I downloaded the updated version you posted here.
Title: Re: [Theme] Lazy Day
Post by: TaliaJoy on January 11, 2019, 04:08:32 am
Is it compatible with 1.1.5?
Title: Re: [Theme] Lazy Day
Post by: radu81 on January 11, 2019, 08:21:41 am
For 1.1.5 you need to use the version uploaded at reply #52 (https://www.elkarte.net/community/index.php?topic=3603.msg37832#msg37832)