Skip to main content
Topic: [RC1] Copying a theme = RSS graphic is missing (Read 1209 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[RC1] Copying a theme = RSS graphic is missing

I made a copy of the default theme via admin center to work with. In the footer of the new theme the RSS graphic is missing.  ;)

Re: [RC1] Copying a theme = RSS graphic is missing

Reply #1
hmm... that graphic comes from awesomefont... could it be the css is not moved?
Bugs creator.
Features destroyer.
Template killer.

Re: [RC1] Copying a theme = RSS graphic is missing

Reply #2
font-awesome.css is copied into the new theme folder.

Edit: But the folder "webfonts" is missing.

Re: [RC1] Copying a theme = RSS graphic is missing

Reply #3
The mobile menu icons are missing too. 

Re: [RC1] Copying a theme = RSS graphic is missing

Reply #4
Good catch ...

For now make a copy of the webfonts directory under the new theme directory you created.

Looks like we need to replicate that directory during the theme copy process.  Part of me wants to put them in a central location so all the themes point to them but there is no ideal way to do that (that I am aware)

ETA: for now fixed here https://github.com/Spuds/Elkarte/commit/ed71cd151884a3eb08fc13265b3a56e9aeb83606

Be safe, Be kind, Happy Programing

Re: [RC1] Copying a theme = RSS graphic is missing

Reply #5
hmm... there should be a better way to create a new theme... O:-)
Bugs creator.
Features destroyer.
Template killer.