Skip to main content
Topic: Migration of SMF to ElkArte (Read 24192 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Migration of SMF to ElkArte

Reply #60

Quote from: emanuele – About the number of topics I'm not sure what to say, the only question that comes to my mind is: did you do a maintenance in SMF before the migration? Maybe the count was already messed a bit.

You are my hero!  :D  Yes, that did it. I counted new in my SMF board and now they are completely the same!  :)

Re: Migration of SMF to ElkArte

Reply #61

Good! One is gone! :D
Bugs creator.
Features destroyer.
Template killer.

Re: Migration of SMF to ElkArte

Reply #62

So, everything seems to be okay with my ElkArte. Just the Aeva Media pictures are missing (wip) and one global moderator don't get e-mail notifications when she gets new messages. Board and topic notifications are working, her profile setting seem to be okay, the mails are not in her spam directory. Strange.

We are still testing, but found no big bugs till now. Just small things. You all did a really great job, thanks a lot!

I wanted to disallow members to choose the default ElkArte theme. They should only choose between board standard (named Skyblue) and a second theme (named Greensleaves). But ElkArte seems to need the default theme chooseable, right? Why?

Re: Migration of SMF to ElkArte

Reply #63

Quote from: Jorin – But ElkArte seems to need the default theme chooseable, right? Why?
IIRC that's inherited from SMF.. Force a specific theme or make all themes choosable...
Thorsten "TE" Eurich
------------------------

Re: Migration of SMF to ElkArte

Reply #64

Any chance for a change? 

Re: Migration of SMF to ElkArte

Reply #65

uuups, there's an option ..
Admin - Configuration -  Themes Management - Manage and Install
Allow members to select their own themes. -> should be checked.
Themes the user is permitted to select: -> deselect the default.
Thorsten "TE" Eurich
------------------------

Re: Migration of SMF to ElkArte

Reply #66

I tried this, but ElkArte said the default theme needs to be set too. I can't deselect it. 

Re: Migration of SMF to ElkArte

Reply #67

I don't know why, but now I can deselect the default theme. Only difference: I use the Firefox browser at my girlfriend's computer right now. I tried it with Chrome before and got the problem.

Re: Migration of SMF to ElkArte

Reply #68

To check I guess.
Bugs creator.
Features destroyer.
Template killer.

Re: Migration of SMF to ElkArte

Reply #69

Quote from: Jorin – It's my production site. So not a test, no. But it's in maintenance mode now.

The code looks like this: [smg id=3661]
No errors in the log?
Can you check via phpmyadmin in the table aeva_settings if the value data_dir_path is correct?
Bugs creator.
Features destroyer.
Template killer.

Re: Migration of SMF to ElkArte

Reply #70

Oh, I have a lot of errors: 99 with wrong login informations of members (can I do something about that? I think it's because I had a modification with SMF that changed user name to e-mail adress at login and maybe a lot of my users use their browsers to save the login informations and now the browser leads to these errors) and 110 with undefined indexes  :o   but it seems none about the aeva gallery.

I can't check the database right now because of missing internet connection at my home at the moment.

Re: Migration of SMF to ElkArte

Reply #71

Quote from: Jorin – Oh, I have a lot of errors: 99 with wrong login informations of members (can I do something about that? I think it's because I had a modification with SMF that changed user name to e-mail adress at login and maybe a lot of my users use their browsers to save the login informations and now the browser leads to these errors)
IIRC the email is fine for the login.

Quote from: Jorin – and 110 with undefined indexes  :o 
Well, if you see anything that may reseble a bug feel free to report it (if you want you can take a dump of the errors table and send it to me by PM so I can filter them out).

Quote from: Jorin – but it seems none about the aeva gallery.
Darn... :P
Bugs creator.
Features destroyer.
Template killer.

Re: Migration of SMF to ElkArte

Reply #72

Sorry I overlooked something: you see the whole bbcode!
This is very important, because it means the code is not used at all.

You should check two things:
1) that the files /sources/subs/Mgal.subs.php and /sources/controllers/Mgal.controller.php are present,
2) in admin > maintenance > forum maintenance > integration hook, check if the hook "integrate_bbc_codes" (first column) has in the second column "Function: mgal_bbcode" and the icon on the right side.
Bugs creator.
Features destroyer.
Template killer.

Re: Migration of SMF to ElkArte

Reply #73

The files weren't there. Now they are, I copied them from your zip onto the server. Point 2 is good.

But it seems it's still not working. Can it be the addon isn't installed correctly? I know see ($1) in my posts.

Re: Migration of SMF to ElkArte

Reply #74

At least is a step in the right direction! :D

And fix that should be easy: go to admin > forum > posts and topics > bulletin board code and tick "smg" to enable it. ;D
Bugs creator.
Features destroyer.
Template killer.