Skip to main content
Topic: Preliminary ElkArte 1.1.10 - Release Notes (Read 3835 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #15

Quote from: Burke Knight – The jumping to the end on modify, was really annoying
LOL yeah, I only just noticed it and was like, what the heck, why is it doing that !

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #16

Quote from: ahrasis – All php8 including 8.3 should be usable on 1.1.10
I never thought the day would come that PHP would be changing faster than the software running on it.

Yes I agree it should, but I've not been testing on it:frowning_face:My dev site is 8.2 and the sites I run are on mostly on 8.2 with a few still back on 7.4 :shushing_face:

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #17

Here is a yet another updated 1.1.10 package.  It has the following changes from the last one

  • Prevent a few more PHP 8.2 depreciation notices that I was able to find
  • Scroll editor to page top when using reply/modify/etc
  • Move a couple of editor startup functions to the ready event in the moveto plugin
  • When editing, ensure the editor view starts at the top the text not the bottom
  • Pagination was not honored when viewing a list of members in a member group (the entire list was shown)
  • Prevent a deferred error in FireFox with the editor custom tags
  • Do not call JS functions when they are not available (seen only as a console error in the ACP)

I've been running the previous patch on a few low traffic sites, and this addresses anything (php) that I saw in the error log

ETA:  This version of the patch file has been removed, be sure to uninstall it when the final is released  :wink:
Last Edit: January 19, 2024, 12:37:52 pm by Spuds

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #18

Welp:punch::punch::head_bandage:

Found a couple of more minor things that I have fixed.

Like Stats:
 - Was showing the top 10 most liked posts, but not in 1-N order, was also showing the count wrong due to wrong value used in template
 - Was not formatting numbers so you would end up with 1234 and not 1,234 or 1.234
 - Was showing the wrong number of likes on a topic, it had the right number but wrong value was used in the template

Structured Data
- Saw a google suggestion that the Datetime property was missing a timezone.  In some more reading that should have been set as ISO8601 or YYYY-MM-DDTHH:MM:SS+00:00 so now it will be.

 

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #19

I found and fixed/enhanced a couple of other things.  Not sure anyone really cares to read these on-going pre-release updates :man_shrugging:  so I'll save myself some time and simply note them in the final release notes.

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #20

Quote from: Spuds – Not sure anyone really cares to read these on-going pre-release updates
But yes. Thanks for your work!  :thumbsup:

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #21

Quote from: Spuds – I found and fixed/enhanced a couple of other things.  Not sure anyone really cares to read these on-going pre-release updates :man_shrugging:  so I'll save myself some time and simply note them in the final release notes.

I do care . Thank you

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #22

Been running 1.1.10 live on a few sites, monitoring for any issues. 

I made one update today, not really a bug, but an inconsistency that you I could only see when running an addon.  It was one of those non-bugs that took 10x as long to figure out as a real bug LOL

Anyway I think its getting close to packing this up as in on my test sites I'm not seeing any errors (well other than users who can't remember their passwords LOL)

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #23

Quote from: Spuds – Here is an updated 1.1.10 package.  It has the following changes

- fixed another php8 issue in bad behavior
- fixed a php8 depreciation notice in spider stats
- fixed gibberish being returned for an empty new board description
- added option to move crawlers into the restrictive group which allows you to limit them to specific boards (easier than robot txt)

Not sure if you noticed this, but after this version of the patch, I make a new board and add description, but for some reason, the description vanishes. As if never entered. Confirmed this on 3 sites. No errors in the log.
Seems like there's something missing when saving, that does not include the description.

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #24

I see that as well ... fixed on my local, it was a side effect of the fix when no description was given.  I've test all the combos I could think of this time and it will be fixed in 1.1.10 final.

Thanks for the report

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #25

Quote from: Spuds – .. fixed on my local, it was a side effect of the fix when no description was given. 

Sounds like my kind of fix - compensate for a "no description" situation and then make everything "no description." Voilla! :stuck_out_tongue: 

(I had a foreman who the business owner decided needed some formal management training, and the next "course" segment  available for him to attend was "Dealing With Problem Employees". It was the only management course he ever took, and from then on his management approach was to turn every employee into a problem employee so he knew how to manage them.)

// Deep inside every dilemma lies a solution that involves explosives //

Re: Preliminary ElkArte 1.1.10 - Release Notes

Reply #26

It kind of made sense when I typed it in last night LOL  :tongue: