Skip to main content
Topic: [1.0.10] cursor position when using "quote" (Read 3876 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[1.0.10] cursor position when using "quote"

1. Start a post without typing a single character. Click on the quote BBC button.

The cursor jumps to this postion (marked in red): [quote] | [/quote] <-- No bug!

2. Write a post (at least some words). Place your cursor in a new line (or anywhere else, makes no difference). Click on the quote BBC button.

The cursor jumps to this postion (marked in red): [quote][/ | quote] <-- Bug!

Re: [1.0.10] cursor position when using "quote"

Reply #1
Browser?
Bugs creator.
Features destroyer.
Template killer.

Re: [1.0.10] cursor position when using "quote"

Reply #2
Happens in FF using the WYSIWYG editor too.  Types right in the quote box.


Re: [1.0.10] cursor position when using "quote"

Reply #4
I must be doing something different, but I can't reproduce that behavior yet.
Be safe, Be kind, Happy Programing

Re: [1.0.10] cursor position when using "quote"

Reply #5
I can reproduce some issue with the WYSIWYG (i.e. when clicking the quote BBC button the cursor basically disappears and I can't write unless I click inside the quote shape), but in with the non-WYSIWYG editor seems to work fine on my test site.
Bugs creator.
Features destroyer.
Template killer.

Re: [1.0.10] cursor position when using "quote"

Reply #6
I am not using the WYSIWYG editor. I will make a video of it later when I'm home.

Re: [1.0.10] cursor position when using "quote"

Reply #7
Maybe this will help?  Quoting using Quick Reply works fine.   Using the Reply page, then Insert Quote works fine.  If you aren't using Quick Reply, then click Quote from the post, the issue arises.  The cursor invariably goes in the Quote box.  It won't come out of the box, even with a hammer.  ;D

Re: [1.0.10] cursor position when using "quote"

Reply #8
Oh, where's my video?  :o

Re: [1.0.10] cursor position when using "quote"

Reply #9
I'm still having trouble creating these behavior(s) (at least on this site) .... sorry !  :'(
Be safe, Be kind, Happy Programing

Re: [1.0.10] cursor position when using "quote"

Reply #10
I'm still having trouble creating these behavior(s) (at least on this site) .... sorry !  :'(
Here is a replication example.
No matter what, I cannot type outside the quote box.

Re: [1.0.10] cursor position when using "quote"

Reply #11
In your Look and Layout, enable WYSIWYG, and disable Quick Reply.  Quote directly from a user's post, not insert from below.

Re: [1.0.10] cursor position when using "quote"

Reply #12
Well, that's strange. I can't replicate it now too!  :o  Not here and not in my board!  :o  :o

Re: [1.0.10] cursor position when using "quote"

Reply #13
In your Look and Layout, enable WYSIWYG, and disable Quick Reply.  Quote directly from a user's post, not insert from below.
Now that I could reproduce and it should be fixed here.
Well, that's strange. I can't replicate it now too!  :o  Not here and not in my board!  :o  :o
Well now I don't feel so bad :D ... could still be an error in there, something with a certain combination of options and how the quote gets inserted.  So many ways to do something can make it difficult to reproduce and fix.
Be safe, Be kind, Happy Programing

Re: [1.0.10] cursor position when using "quote"

Reply #14
Thanks Spuds!  You da man!!!  Woot!!!   ;D



Is there a fix for us?   ;)