Skip to main content
Topic: [1.0.10] cursor position when using "quote" (Read 3873 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: [1.0.10] cursor position when using "quote"

Reply #15
More of a trick than a fix  O:-)

Open your themes/default/scripts jquery.sceditor.elkarte.js file ... find:
Code: (find) [Select]
			content = '<blockquote author="' + attr_author + '" link="' + attr_link + '" date="' + attr_date + '"><cite>' + sAuthor + ' ' + sDate + '</cite>' + content + '</blockquote>
Code: (replace) [Select]
			content = '<blockquote author="' + attr_author + '" link="' + attr_link + '" date="' + attr_date + '"><cite>' + sAuthor + ' ' + sDate + '</cite>' + content + '</blockquote>&nbsp;';
So just adding a trailing &nbsp; to somewhat trick the editor
Be safe, Be kind, Happy Programing

Re: [1.0.10] cursor position when using "quote"

Reply #16
Sorry to ressurect this thread, but 1.1.8 is having similar issues again.  :o

Re: [1.0.10] cursor position when using "quote"

Reply #17
It may be a few days before I can look into this :(
Be safe, Be kind, Happy Programing

Re: [1.0.10] cursor position when using "quote"

Reply #18
It may be a few days before I can look into this :(

After updating to ElkArte 1.1.8, some users began to complain about glitches when quoting. The text of the user's response is placed inside the quote.
Community of forum owners on any forum engine (сообщество владельцев форумов на любом форумном движке) https://forumovod.ru

Re: [1.0.10] cursor position when using "quote"

Reply #19
It may be a few days before I can look into this :(

After updating to ElkArte 1.1.8, some users began to complain about glitches when quoting. The text of the user's response is placed inside the quote.

forumovod - did you edit your post,  or did I just have another glitch come floating into my email inbox?

> On: Tue Aug 15, 2017 badmonkey Wrote:  
>
> Is there a fix for us?  ;)  

After updating to ElkArte 1.1.8, some users began to complain about glitches
when quoting. The text of the user's response is placed inside the quote.
__________________________________________________________________________
// Deep inside every dilemma lies a solution that involves explosives //

Re: [1.0.10] cursor position when using "quote"

Reply #20
Quote
forumovod - did you edit your post,  or did I just have another glitch come floating into my email inbox?

Yes, I first quoted the old message, and then I saw that there is a newer answer in the topic. Therefore, I corrected the quote.
Community of forum owners on any forum engine (сообщество владельцев форумов на любом форумном движке) https://forumovod.ru

Re: [1.0.10] cursor position when using "quote"

Reply #21
Cool - I presume Spuds breathes a temporal sigh of relief..
__________________________________________________________________________
// Deep inside every dilemma lies a solution that involves explosives //

Re: [1.0.10] cursor position when using "quote"

Reply #22
Attached is a test build to see if it fixes the issue for everyone.  Replace the file in /themes/default/scripts (make a copy incase you find this version worse)

Some notes!

- The quote regression error looks like it happened in 1.1.7 when we made some fixes that prevent possible XSS via the editor.  There was really no proof of concept but certainly a weakness we cleaned up.
- Since I will have to spin a new release at some point, I decided to pulled in several improvements from 2.0 into this update, so there could be other bugs, see there is no free lunch here.  The improvements that I recall are:

1) If you selected several lines of text and "list" they would all be in one bullet, now each line will be a bullet
2) Current editor does not work with the quick list item codes, this version should
3) tt/pre should now allow selecting the toolbar icon to end the tag if you are in that tag or start a one otherwise.  Also selecting text in those tags should remove the formatting.  Basically it attempts to make those tags act like native tags bold, italic, etc.  Yes there are still quirks.
4) Misc stuff
Be safe, Be kind, Happy Programing

 

Re: [1.0.10] cursor position when using "quote"

Reply #23
Attached is a test build to see if it fixes the issue for everyone.  Replace the file in /themes/default/scripts (make a copy incase you find this version worse)



Thanks spuds! I've deployed on a pair of sites. The quote fix appears to be working. No feedback on the other elements so far.