Skip to main content
Topic: Difficulties to find my theme (Read 2193 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Difficulties to find my theme

It seems that ElkArte does not really work well with XAMPP on Windows.

I tried to load my theme (WIP, TBA) by entering the path on the Theme Management site but it just created a new one.

 ::)
-

Re: Difficulties to find my theme

Reply #1
Sounds almost like a bug to me...
I'll try to test it tomorrow.
Bugs creator.
Features destroyer.
Template killer.

Re: Difficulties to find my theme

Reply #2
It works on OS X but not on Windows 10, at least.  :o
-

Re: Difficulties to find my theme

Reply #3
Then XAMPP is not fully compatible with Win 10...?
~ SimplePortal Support Team ~

Re: Difficulties to find my theme

Reply #4
XAMPP works, ElkArte works - the path does not.
-

Re: Difficulties to find my theme

Reply #5
Exactly, maybe some XAMPP functions are broken (heck, how could you even set it up? I tried, it's a mess) ;D But I'd rather wait for emanuele on this one
~ SimplePortal Support Team ~

Re: Difficulties to find my theme

Reply #6
It works on OS X but not on Windows 10, at least.  :o
TBH I never tried windows server (mainly because my windows machine is a terribly old netbook that barely runs a notepad and a browser at the same time LOL), but guessing from the code and your description, I think the "problem" may be in that line:
Code: [Select]
elseif (isset($_REQUEST['theme_dir']) && rtrim(realpath($_REQUEST['theme_dir']), '/\\') != realpath(BOARDDIR . '/themes') && file_exists($_REQUEST['theme_dir']))
1088 of ManageThemes.controller.php (ADMINDIR).
Could it be you are trying to install the theme from another directory that BOARDDIR/themes?
I should go back and check, but I guess the trstriction was done for security reasons, though it probably doesn't cover all the possible alternatives (like a themes dir outside BOARDDIR, that is a possibility).
It may either be a problem with the path, or realpath having issues with windows, or even a dir names case problem (e.g. one is upper, one is lower case), in that case we may need to differentiate the behaviour between win and *nix.
Bugs creator.
Features destroyer.
Template killer.

Re: Difficulties to find my theme

Reply #7
I tried installing it even from my desktop with no real success.
-

Re: Difficulties to find my theme

Reply #8
Moved to bug reports for now.
Bugs creator.
Features destroyer.
Template killer.

Re: Difficulties to find my theme

Reply #9
^ Anything new? I have a free week and would really love to continue working on my theme.
-

Re: Difficulties to find my theme

Reply #10
I cannot reproduce it on win7 and I don't have a win10 handy, so it's kind of impossible to test it for me... :(
Bugs creator.
Features destroyer.
Template killer.

Re: Difficulties to find my theme

Reply #11
 :o  ::)  >:(
-

Re: Difficulties to find my theme

Reply #12
I understand the whole not here. With me working ElkArte (1.04 1.0.5 and 1.1beta) with Xampp under Win 10 32 and 64 bit without errors. All functions. The XAMPP works properly is in C: be directly installed.
Regards Stephan