Skip to main content
Topic: [v1.1.1] Editor system (Read 2821 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[v1.1.1] Editor system

Hello.

Friends, I found a bug in the editor. Bug: After writing the text, press twice on the view source and when the HTML system is open, the system crashes. Will you fix it?

How can we just cancel the source part until this problem is fixed?


Re: [v1.1.1] Editor system

Reply #1
What browser are you using?
With your instructions, I tried it here and it seems to work.
What I did is:
1) setting "Show WYSIWYG editor on post page by default" set to off,
2) went to the reply page
3) wrote something,
4) clicked on the "view source" icon once
5) clicked on the "view source" icon a second time
And there is no problems.
My current browser is seamonkey 2.40 (somehow old indeed).

Can you describe the steps to reproduce the error like I did with my list?
Thanks. :)
Bugs creator.
Features destroyer.
Template killer.

Re: [v1.1.1] Editor system

Reply #2
1) I use Mozilla Firefox, can it also be a translation package?

Re: [v1.1.1] Editor system

Reply #3
Please provide any detail you can, even better if you have a step-by-step procedure to replicate it 100%.
Bugs creator.
Features destroyer.
Template killer.

Re: [v1.1.1] Editor system

Reply #4
Does that markup in that screenshot look weird or is it just me? Looks like some of it has special meaning to the editor, at least the ones with the sceditor classes.

Re: [v1.1.1] Editor system

Reply #5
Please provide any detail you can, even better if you have a step-by-step procedure to replicate it 100%.

Okay, I'll take the video and assign the error.

Does that markup in that screenshot look weird or is it just me? Looks like some of it has special meaning to the editor, at least the ones with the sceditor classes.
Yes, at least you could use CKeditor.

Re: [v1.1.1] Editor system

Reply #6
Yes, at least you could use CKeditor.
Well, if you go by that reasoning, any time we find a bug in elk we should switch to either phpbb or mybb?
First let's confirm the bug, then let's fix it.
And if you feel like CK is much better, propose a comparison in the appropriate section along with an estimate of the amount of work needed to implement the custom bbcodes present in elk. :)
Bugs creator.
Features destroyer.
Template killer.

Re: [v1.1.1] Editor system

Reply #7
Let's look at a weekend to correct the error.

Re: [v1.1.1] Editor system

Reply #8
Hi.

Let me review your site assignment.

Re: [v1.1.1] Editor system

Reply #9
Tested on the site (both English and Turkish), but I could not reproduce.
Firefox 50.1 on linux.
At the moment I cannot test with anything else.
Feel free to provide more details like:

  • operating system,
  • version of firefox,
  • if it happens after clearing the cache of the browser,
  • if it happens with a different account
  • anything else.
Bugs creator.
Features destroyer.
Template killer.

Re: [v1.1.1] Editor system

Reply #10
Microsoft Windows 7 Proffessional 64 Bit
Mozilla Firefox Quantum 57.0.4
Cache delete no.
Different Account no.
no...

Re: [v1.1.1] Editor system

Reply #11
The last three "no" mean that it works or it doesn't work?
Sorry to be picky, but being very clear in these cases is one of the most important things. ;)
Bugs creator.
Features destroyer.
Template killer.

Re: [v1.1.1] Editor system

Reply #12
Hi emanele.

I mean the problem is only in Mozilla Firefox Quantum.

Re: [v1.1.1] Editor system

Reply #13
I can't reproduce the crash in Fx 57. Using this forum (elkarte.net/community) I wrote a text with a few more or less random formatting options applied (bold, italic, an ordered list) and clicked view source a few times to toggle back and forth. Is there anything I'm missing?

My test system is Xubuntu 17.10 x64 with Firefox 57.0.4.

As an aside, if it only happens in Fx 57 I'd be more inclined to call it an Fx 57 problem. :)

Re: [v1.1.1] Editor system

Reply #14
It's the emoji addon.
@Spuds that's for you! :P

BTW as far as I can tell the addon is broken because it always adds the full image tag in... "plain text" (i.e. it's always visible the whole <img src blablabla /> instead of the actual image)
Bugs creator.
Features destroyer.
Template killer.