Skip to main content
Topic: [Theme] Separation (Read 15655 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: [Theme] Separation

Reply #45

Quote from: Spuds – Here is an update which should address several of the issues and have better compatibility with 1.1.9  If you have made modifications to the theme, you will have to manually merge those back.

It appears to have fixed the issues, including the inline attachments issue.
However, when running SP, it seems to give some errors in the log, when in the admin panel,
but only when on the Current Theme page. (I also notice, all blocks that are visible "Everywhere" are duplicated on this page only.

Code: [Select]
Type of error: General
Notice: Constant SPORTAL_VERSION already defined
/index.php?action=admin;area=theme;sa=list;th=3
File: /sources/subs/Portal.subs.php
Line: 61

Code: [Select]
Type of error: General
Notice: Constant SPORTAL_STALE already defined
/index.php?action=admin;area=theme;sa=list;th=3
File: /sources/subs/Portal.subs.php
Line: 62

Portal.subs.php - Lines 61 & 62:
Code: [Select]
	define('SPORTAL_VERSION', '1.0.1');
define('SPORTAL_STALE', 'sp101');

Errors and duplications were not an issue before.

Re: [Theme] Separation

Reply #46

Off to look .... I think I know what I did this time  :shocked:   Thanks for the feedback

Re: [Theme] Separation

Reply #47

Looking at my "current" SP version which will be SP 1.0.2, I had already changed lines 61/62 to be:

Code: [Select]
	defined('SPORTAL_VERSION') || define('SPORTAL_VERSION', '1.0.1');
defined('SPORTAL_STALE') || define('SPORTAL_STALE', 'sp101');

To prevent that error.  There are a few things in motion when you add/change themes, so the above change simply helps prevent the error.  Of course my version is 1.0.2 but just use the above line until I release it.

 

Re: [Theme] Separation

Reply #48

Quote from: Spuds – Looking at my "current" SP version which will be SP 1.0.2, I had already changed lines 61/62 to be:

Code: [Select]
	defined('SPORTAL_VERSION') || define('SPORTAL_VERSION', '1.0.1');
defined('SPORTAL_STALE') || define('SPORTAL_STALE', 'sp101');

To prevent that error.  There are a few things in motion when you add/change themes, so the above change simply helps prevent the error.  Of course my version is 1.0.2 but just use the above line until I release it.


That solved the errors. However, not the duplicate blocks on the Current Theme page.