Skip to main content
Topic: ElkArte 1.1.9 (Read 3010 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: ElkArte 1.1.9

Reply #75

"Testing" is underway!  Thanks again @Spuds 

Re: ElkArte 1.1.9

Reply #76

Quote from: Spuds – Once again, I think 1.1.9 is about readytm  I'll post the latest patch package FOR TESTING after this note. 

This update should address all of the items brought up in this thread, plus some reported on github, some pm reported, and some just found.  The only open issue that is not addressed (that I am aware) is one @radu81 reported where the WEBP ILA  in preview mode appears to be full resolution, seems like RL has consumed him for now so work on that will have to wait  :wink:

Note its important to get 1.1.9 finalized as the 1.1.8 install package does not work on PHP 8.1 and PHP 7.4 is essentially EOL at this point (in terms of support and security patches).  I may update the 1.1.8 install package.

{snip}


Apologies if this appears to be a stupid (or redundant) suggestion, but if it's not listed up front in a "system requirements" section of the package description for download, it might be handy to note what PHP versions are supported by each EA version. While 7.4 is on the cusp of EOL, it is the latest version available to me unless I want to go outside of my host-provided packages. (I'm not sure if that lack of newer options is due to platform compatibility issues or a missing round-tuit, but it is what it is.)

And, since EA isn't the only code package running on my server, every time I upgrade my PHP version I have to run compatibility checks on everything else too, and stepping up to 7.x for another application forced me to replace several other legacy applications I was running with ones that weren't limited at 5.6, and then port over the data (square-peg/round hole exercise).  Consequently I'm not sure what else is going to break if I were to step up to v. 8.x

Not that I'm looking to upgrade (I suspect what I have running now will live longer than I and most of my users will), but if it's not there already somewhere, others may find that version compatibility information "up front" nice to know, ya know.. :undecided:

-=In the readme.md file in 1.16 (for example) - says it's good with PHP 5.3 "and newer" but... "how much newer?". Like 8.3? If 1.1.8 doesn't play well with 8.x, I suspect 1.1.6 won't either.
Last Edit: January 17, 2023, 12:36:54 am by Steeley

// Deep inside every dilemma lies a solution that involves explosives //

Re: ElkArte 1.1.9

Reply #77

Was going to try it on one of my not-so-active forums, but seem to have way too many errors due to my theme.
Separation by @Spuds is the theme.
Here's list of the errors: (Only the failed edits listed)

Code: [Select]
Separation
Execute Modification ./themes/elk_theme_separation_11/Display.template.php Test failed
1. Replace ./themes/elk_theme_separation_11/Display.template.php Test failed
2. Replace ./themes/elk_theme_separation_11/Display.template.php Test failed
3. Replace ./themes/elk_theme_separation_11/Display.template.php Test failed
4. Replace ./themes/elk_theme_separation_11/Display.template.php Test failed
5. Replace ./themes/elk_theme_separation_11/Display.template.php Test failed
6. Replace ./themes/elk_theme_separation_11/Display.template.php Test failed

Execute Modification ./themes/elk_theme_separation_11/MessageIndex.template.php Test failed
1. Replace ./themes/elk_theme_separation_11/MessageIndex.template.php Test failed
2. Replace ./themes/elk_theme_separation_11/MessageIndex.template.php Test failed

Execute Modification ./themes/elk_theme_separation_11/css/index.css Test failed
1. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
3. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
4. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
5. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
6. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
8. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
10. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
11. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
12. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
13. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
14. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
17. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
20. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
22. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
23. Replace ./themes/elk_theme_separation_11/css/index.css Test failed
26. Replace ./themes/elk_theme_separation_11/css/index.css Test failed

Execute Modification ./themes/elk_theme_separation_11/css/rtl.css Test failed
2. Replace ./themes/elk_theme_separation_11/css/rtl.css Test failed

Execute Modification ./themes/elk_theme_separation_11/index.template.php Test failed
1. Replace ./themes/elk_theme_separation_11/index.template.php Test failed
2. Replace ./themes/elk_theme_separation_11/index.template.php Test failed

Re: ElkArte 1.1.9

Reply #78

I think that is normal for custom themes, right?


Re: ElkArte 1.1.9

Reply #80

Except for the message "/sources/subs/Portal.subs.php    File not found", it slips through easily.
Vanilla installation without portal. Therefore the logical error message. ;)
As always good work @Spuds:thumbsup:

Re: ElkArte 1.1.9

Reply #81

That is to cover the portal, if one has it installed, I think.

Re: ElkArte 1.1.9

Reply #82

Quote from: ahrasis – That is to cover the portal, if one has it installed, I think.
That is correct.  If you fail to upgrade the portal then you would either get a hacking attempt or a 500 error.  I added the portal edit in the 1.1.9 package simply to avoid someone breaking there forum during an upgrade.  I would not normally do that, but in this case it seemed prudent.

Re: ElkArte 1.1.9

Reply #83

Quote from: ahrasis – I think that is normal for custom themes, right?
Oh yeah! ... The patch file will give it a "go" but if the theme made modification to the same area (even an extra space), it will simply not be able to do anything.  The (generally) good thing is that the custom theme should still work as is, it will just lack the new features.

In adding the quick quote, quote more, and structed data capability, it meant edits to index.template and display.template both of which are some of the most commonly edited files when making a custom theme.  I've done my best to outline how/what to edit in a serries of "how to add the 1.1.9 xyz to your theme" posts under the theme board.

Re: ElkArte 1.1.9

Reply #84

Thanks for the update. I decided to give it a try on our site. I did make a change to facilitate my git based release management and the need to update the database:


Please consider supporting git merge for release updates like this, which can be accomplished via upgrade.php.

 

Re: ElkArte 1.1.9

Reply #85

@nwsw  that is an awesome idea !!