Skip to main content
Topic: Cannot delete a mentioned member in the editor (Read 1205 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Cannot delete a mentioned member in the editor

Hi, i think I just found a bug in 1.1.1 version installed on elkarte.net. I am not sure if it's a bug or something related to my phone or my keyboard phone since after the last updates has some problems inserting the correct words suggested by the dictionary.

Anyway to replicate try from mobile to answer to a topic something like this:

Hello @emanuele‍ how are you?

Now try to delete from the end of line, when I arrive to the mentioned member the keyboard disappear and I cannot delete the mentioned member. I tried a few times without results. On 1.0 version I don't have this problem. (edit: same behaviour on 1.0.x version with visual editor enabled)

If could be important to replicate, I use the full editor under the last post and visual editor active.
sorry for my bad english

Re: Cannot delete a mentioned member in the editor

Reply #1
jhiuhui @radu81 test
Bugs creator.
Features destroyer.
Template killer.

Re: Cannot delete a mentioned member in the editor

Reply #2
Same behaviour on 1.0.10 if visual editor is turned on.
There is no need to publish the message, just write it, then try to delete the text

No problems using the PC
sorry for my bad english

Re: Cannot delete a mentioned member in the editor

Reply #3
The one you are describing seems a general problem of the code used to create the "@" thingy:
https://github.com/ichord/At.js/issues/519

But (and there is always a but and a bug), apparently I'm having issues also on the desktop (and that's the reason I posted the message before).
If I start mentioning my name, in chrome the popdown is shown only every even letter (while if I use my old version of seamonkey it stops after I type the 3rd letter...

I wonder when it started screwing up... :-\
Bugs creator.
Features destroyer.
Template killer.