Skip to main content
Topic: Quotes (Read 610 times) previous topic - next topic - Topic derived from Quotes
0 Members and 1 Guest are viewing this topic.

Quotes

Hi!

An old topic, but maybe this issue is something simulaire?

I noticed right now on test forum (ElkArte 1.1.9 php 8.1?), that if WYSIWYG-Editor is used
you cannot type proper in editor, if you quote first or if you edit a post, which contains a quote.

The cursor will stay in the "quote field". You could type into this quote but not beyond.
If you change back to the normal view (view source), typing beyond the quote will be possible again.
Last Edit: March 19, 2023, 03:08:44 pm by Administrator

Re: Quotes

Reply #1

Split and moved this ...

I was able to reproduce this behavior when I turned off the quick reply option in my profile and enabled wizzy as the default.  At that point when you select quote you go to the full editor and the cursor was stuck in the quote box. 

I think I found the issue deep:pick:inside the editor, and I've attached an updated build for testing.  There was already a function being called to prevent this problem, but there were a couple of issues that caused it to fail.  Anyway just replace the one in themes\default\scripts with this version and give it a test.

Re: Quotes

Reply #2

Thank you very much, Spuds. :smiley:

I tried your file. It is working almost, if you quote or are editing a post with a quote.
Then you can change to WYSIWYG and can type now in editor.

But if the settings in profile say "use WYSIWYG editor", then it does still not work.

Re: Quotes

Reply #3

Be sure to clear your cache to ensure its using the new file.

Re: Quotes

Reply #4

Yes...I just did...also cleared cache on test forum.

It is working now! Great! :smiley:  Thank you!

Re: Quotes

Reply #5

Glad its working :D


Re: Quotes

Reply #7

Should be safe for anyone on 1.1.x
Certainly 1.1.7+ but its not like I can realistically test every combination of this and Elk like a Mr. Potato head:potato:LOL  :cheesy:


Re: Quotes

Reply #9

Do it !!! (I did to my sites)