Skip to main content
Guest Posting issue Started by DeadMan · · Read 5047 times 0 Members and 2 Guests are viewing this topic. previous topic - next topic

Guest Posting issue

Have regular verification disabled, and reCPATCHA addon installed and set up.
ElkArte - 1.1.8
reCaptcha - 1.0.1

When guest tries to post gets:
guestpost.png

Here are the settings: (reCAPTCHA keys blotted out.)
spamsettings.png


Also, if uncheck "Guests must pass verification when making a post" then guest gets a "This topic doesn't exist" error when submit, instead of being taken back to the board. Not sure if this is what supposed to happen when posts have to be approved, but would expect it to say the post has been submitted, then take back to board.

Re: Guest Posting issue

Reply #1

Sorry for the delay.

Looks like you did not click the not a robot box and tried to post.   The response message is an EllArte standard, I did not create a special $txt string for the addon.  Perhaps a bit lazy, but hey.

You have two options.
1) You can change that by editing the $txt['error_wrong_verification_code'] string in Errors.english.php  and make it what you want.
2) Alternatively there is an available response of Please complete the verification section below to complete your post.  That makes a lot more sense in this instance.  To do that you need to edit the reCaptcha.class.php file and in that find the (2) instances of wrong_verification_code and change them both to need_qr_verification  I'll probably spin a new version to do the same.

Re: Guest Posting issue

Reply #2

I was clicking.
However, I think I solved the main issue.
I had to recopy the keys for the reCaptcha. No idea why that worked, as they were correct.

Re: Guest Posting issue

Reply #3

Could be da google had not activated them yet, sometimes there is a delay.  But either way, glad its working :D