Skip to main content
After changing the PHP version, thousands of time error messages are reported Started by Mrs. Chaos · · Read 5171 times 0 Members and 1 Guest are viewing this topic. previous topic - next topic

After changing the PHP version, thousands of time error messages are reported

Hello,

for two days now, thousands of time error messages have been created daily in the forum. I have not changed anything in the forum and the 24-hour format is still set.
However, two days ago I changed the PHP version of all my domains from 8.0 to 8.1 (8.1.22) and therefore I suspect that this has something to do with it.

What do I have to change in the subs.php and logging.php codes to make the errors disappear? Or does something have to be changed somewhere in the admin centre because of PHP 8.1 ?
Attached are screenshots of all error messages.

Kind regards

Re: After changing the PHP version, thousands of time error messages are reported

Reply #1

What is your forum ElkArte version?

Re: After changing the PHP version, thousands of time error messages are reported

Reply #2

Oh, I'm still using version 1.1.8 on the forum...
Are there any problems with PHP 8.1 and should I better update to 1.1.9 ?

P.S.:  Is it already certain when version 1.1.10 will be released? :wink:
Last Edit: December 02, 2023, 09:08:50 am by Mrs. Chaos
ElkArte version: 1.1.8 / Theme: BeSocial / PHP 8.0

Re: After changing the PHP version, thousands of time error messages are reported

Reply #3

Depending on how adept you are with php, the suggestions in this may help @Mrs. Chaos ..

https://php.watch/versions/8.1/strftime-gmstrftime-deprecated

...or at least kudos for the heads up  {weak grin}

Then again, rolling back to 8.0 until a patch is in may be the easiest option..

[Update: v1.1.9 supports php 8.x according to the gurus, @Spuds can confirm whether that extends to strftime/gmstrftime going forward to php 9.0 eliminating it completely, if you wish confirmation before choosing that option..]
Last Edit: December 02, 2023, 01:48:55 pm by Steeley

// Deep inside every dilemma lies a solution that involves explosives //

Re: After changing the PHP version, thousands of time error messages are reported

Reply #4

I think it's best for me is if I will roll back to 8.0, because the forum ran without any problems.
And then I will have a look at the other suggestions and possibilities. However, I have just little knowledge of PHP...

Regarding a patch for 8.0:
Will there possibly be one soon? Is one already being worked on?
ElkArte version: 1.1.8 / Theme: BeSocial / PHP 8.0

Re: After changing the PHP version, thousands of time error messages are reported

Reply #5

You might be able to fix this via .htaccess, instead of resetting all sites to the earlier php.

Code: [Select]
AddHandler application/x-httpd-alt-php80___lsphp .php

On a side note, I'm running 8.1 and am not getting those time errors.
However, I'm running ElkArte 1.1.9...

 

Re: After changing the PHP version, thousands of time error messages are reported

Reply #6

Only ElkArte version 1.1.9 fixes a lot of php 8.x problems, so unless you are upgrading to that stay with your older php.

Re: After changing the PHP version, thousands of time error messages are reported

Reply #7

FYI; I fixed the strftime issue in Elkarte 1.1.9.

It should work for all languages, but I didn’t manage to test every combination.

Re: After changing the PHP version, thousands of time error messages are reported

Reply #8

Quote from: Mrs. Chaos – P.S.:  Is it already certain when version 1.1.10 will be released?
It will be released, but I don't have a current timeline.   I thought 1.1.9 would be the last 1.1 release but there were a few issues raised that I just don't feel right in not fixing.
Quote from: ahrasis – Only ElkArte version 1.1.9 fixes a lot of php 8.x problems, so unless you are upgrading to that stay with your older php.
:point_up_2:Truth !

Re: After changing the PHP version, thousands of time error messages are reported

Reply #9


I think I will also switch to 1.1.9 in the next few weeks, but first I want to check whether all installed add-ons will run under this version.
ElkArte version: 1.1.8 / Theme: BeSocial / PHP 8.0