Skip to main content
Topic: Getting Fatal Error with OpenImporter when migrating from MyBB 1.6 to ElkArte (Read 1746 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Getting Fatal Error with OpenImporter when migrating from MyBB 1.6 to ElkArte

When I use OpenImporter to migrate from MyBB 1.6 to ElkArte 1.0, I get this error:

Fatal error: Cannot use object of type Configurator as array in /home/kenwan16/kz-climb.com/importer/Importers/elkarte1.0/mybb16_importer.php on line 40

I took a look at the php code, but I couldn't figure it out. Anyone have any ideas?

Thanks in advance!

Re: Getting Fatal Error with OpenImporter when migrating from MyBB 1.6 to ElkArte

Reply #1

Where did you obtain OpenImporter?
If you downloaded the whole repo, depending on the version you used, it may very well be it's missing all the composer stuff.
If you downloaded one of the packages I put together it is likely a bug. :)

Re: Getting Fatal Error with OpenImporter when migrating from MyBB 1.6 to ElkArte

Reply #2

The version I used was the version at GitHub (https://github.com/OpenImporter/openimporter). I also tried downloading from the GitHub IO page which didn't work either. What finally did the trick was downloading the old version found on here: http://www.elkarte.net/community/index.php?topic=2118.0


Thanks for the help! :)

Re: Getting Fatal Error with OpenImporter when migrating from MyBB 1.6 to ElkArte

Reply #3

The one you downloaded last is not the "old version", but actually the most recent. ;)
So yeah, probably you were just hitting some missing stuff.

ETA: one thing I forgot about the version you used, pay attention, because in certain conditions it may show a wrong page giving the idea it's finished, but it still has to do almost everything.
In case, simply refresh the page is enough. ;D