Skip to main content
white screen instead of popup Started by Ruth · · Read 6472 times 0 Members and 1 Guest are viewing this topic. previous topic - next topic

white screen instead of popup

Hi!

Normally a sort of popup will appear, if a questionmark in the admin center is clicked.
But this string on line 192 in Help.english.php/Help.german.php is acting strange.
This help text is to see, where the settings of a certain theme can be done.

Code: [Select]
$helptxt['theme_settings'] = '<strong>Theme Settings</strong><br />
The settings screen allows you to change settings specific to a theme. These settings include options such as the themes directory and URL information but
also options that affect the layout of a theme on your forum. Most themes will have a variety of user configurable options, allowing you to adapt a theme
to suit your individual forum needs.';

A white screen will appear with proper displayed text on the top of it and a link for "return", which does not work?
There are no errors in the log.

Re: white screen instead of popup

Reply #1

I confirmed the same thing  for that theme setting help function, in v 1.1.6, but at least the link for return works..
I was looking at the source for both the page ,and the "pop up" (er..over) and comparing it to other pages and pop ups, looped around Jupiter and crashed into the sun..   but.. yea.. it's goofy.

// Deep inside every dilemma lies a solution that involves explosives //

Re: white screen instead of popup

Reply #2

You are finding all of the dark corners of ElkArte  :tongue:

That is an odd error, and it appears to be caused by the default JavaScript variables not being loaded.   You can edit the Theme.php file in your sources directory.  Towards the top (should be line 108) you will find the following
Code: (find) [Select]
		$this->js_files = &$GLOBALS['context']['js_files'];
Then add the following line after that
Code: (add) [Select]
		$this->js_vars = &$GLOBALS['context']['js_vars'];

Re: white screen instead of popup

Reply #3

Thank you, Spuds. :) I will try it.

QuoteYou are finding all of the dark corners of ElkArte  :tongue:

I thought, better to tell it....

Re: white screen instead of popup

Reply #4



Quote from: Spuds – You are finding all of the dark corners of ElkArte  :tongue:

That is an odd error, and it appears to be caused by the default JavaScript variables not being loaded.   You can edit the Theme.php file in your sources directory.  Towards the top (should be line 108) you will find the following
Code: (find) [Select]
		$this->js_files = &$GLOBALS['context']['js_files'];
Then add the following line after that
Code: (add) [Select]
		$this->js_vars = &$GLOBALS['context']['js_vars'];


Annnnndddd....it's gone! :thumbsup:  :hugging:

// Deep inside every dilemma lies a solution that involves explosives //

Re: white screen instead of popup

Reply #5

I changed this file right now for both forums.  :smiley:  It worked.