Skip to main content
Topic: ElkArte 1.1.7 Patch Testing (Read 23520 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: ElkArte 1.1.7 Patch Testing

Reply #45


In Editor.subs.php you have a commented out line in the icons array, this is causing the update to fail. If you fix that it should work.
Code: [Select]
//array('value' => 'vidéo', 'name' => $txt['icon_camera']),

In the MessageTopicIcons.class.php on line 74 you have the following
Code: [Select]
$this->_stable_icons = array_merge($this->_stable_icons, array_column($custom, 'first_icon'));  

It should be
Code: [Select]

        $custom_icons = array_map(function($element) {                                                                                                                                                         
                 return $element['first_icon'];                                                                                                                                                                     
         }, $custom);                                                                                                                                                                                           
        $this->_stable_icons = array_merge($this->_stable_icons, $custom_icons);

If you correct those two differences the patch should pass.

Re: ElkArte 1.1.7 Patch Testing

Reply #46

Hi tino,
I deleted the line in Editor.subs.php and no more error for this file.
But for the second i made like you said but still the same error : i read and read again but don't see what is different !
The code in the file :
Code: [Select]
		$this->_loadStableIcons();

// Merge in additional ones
$custom_icons = array_map(function($element) {                                                                                                                                                        
                 return $element['first_icon'];                                                                                                                                                                    
         }, $custom);                                                                                                                                                                                          
        $this->_stable_icons = array_merge($this->_stable_icons, $custom_icons);

$this->_loadIcons();
}

/**
* Return the icon specified by idx, or the default icon for invalid names
*
* @param int|string $idx
* @return string
Thank you again for your help.
Philippe

Re: ElkArte 1.1.7 Patch Testing

Reply #47

It's the formatting which is slightly out. Try the attached file Ok I can't seem to upload anything to here and get error's.

You need to check the spacing as it is slightly out in your copied code. Try the below

Code: [Select]
    // Merge in additional ones
    $custom_icons = array_map(function($element) {
      return $element['first_icon'];
    }, $custom);
    $this->_stable_icons = array_merge($this->_stable_icons, $custom_icons);

Re: ElkArte 1.1.7 Patch Testing

Reply #48

A great THANK'S : it works.
I can't also upload anything !

Re: ElkArte 1.1.7 Patch Testing

Reply #49

Quote from: Spuds – Attached is the latest 1.1.7 patch package ... it incorporates feedback from this thread, a few items from php7.4, error log entries that could be address, and another small drafts bug.  Oh yes I forgot about that double // issue  :-[ if I remember to check I'll add it in the final release.

If you are running the previous patch, just uninstall first, then replace the old package with this one and reinstall.
Just got around to trying this on local (running 7.1.24). Installs and uninstalls without errors. I need a new local that runs up to date PHP.  :P

Will set up an online test site too (Liroy's server is currently on 7.2 by default, but I can bump it to 7.3 or 7.4 for testing).
Master of Expletives: Now with improved family f@&king friendliness! :D

Sources code: making easy front end changes difficult since 1873. :P

Re: ElkArte 1.1.7 Patch Testing

Reply #50

Awesome, thank you for testing.  With 1.1.7 you should be fine up to 7.4 :D

Re: ElkArte 1.1.7 Patch Testing

Reply #51

Just applied a small refresh to the 1.1.7 update on this site.  The last patch file I posted was missing a file used in desktop notifications and there were a couple of additional small issues found and resolved.   I've bundled up the new patch but want to test it before I post it.

Re: ElkArte 1.1.7 Patch Testing

Reply #52

Can you fix the error when calling insert?

It throws a depreciated error on the first param having a default and the others not. I don’t see why it’s set on that one myself.

I’ll do a PR if you’d like, I’ve not seen any errors changing it and a grep didn’t show any cases where it would cause an issue, unless I’m blind!

Re: ElkArte 1.1.7 Patch Testing

Reply #53

I have not seen that one ... but yes make a PR to the 1.1.7 patch branch and I'll get it in the patch!

Re: ElkArte 1.1.7 Patch Testing

Reply #54

Quote from: Spuds – I have not seen that one ... but yes make a PR to the 1.1.7 patch branch and I'll get it in the patch!

I’ll do it tomorrow, it doesn’t show in the Elkarte error log, does on the Apache one.

Re: ElkArte 1.1.7 Patch Testing

Reply #55

I don't know if it is because of the patch 1.1.7 but i now only have it.
When a new member registers he must activate his account with a link in an email.
He receives the email but the link to activate return an error :
capture5.png
On Back the page stays the same, always.
But if the member tries to login it works.
There is no error in the logs.

It seems that's the message is not the good one.

Re: ElkArte 1.1.7 Patch Testing

Reply #56

Maybe he clicked twice on the link to confirm registration.

I just checked on my test forum and I cannot reproduce this error, it works.

Re: ElkArte 1.1.7 Patch Testing

Reply #57

Hi,
I tried myself and i have the same thing with only one click.
You can try at https://augras.eu/forum_zwii(it's an elkarte to test for a new forum : but by default it is in french).

Re: ElkArte 1.1.7 Patch Testing

Reply #58

Quote from: augras – Hi,
I tried myself and i have the same thing with only one click.
You can try at https://augras.eu/forum_zwii (it's an elkarte to test for a new forum : but by default it is in french).

Which version of EA did you upgrade from augras? (Or rather, what was the last version that you know worked properly?)

// Deep inside every dilemma lies a solution that involves explosives //

Re: ElkArte 1.1.7 Patch Testing

Reply #59

@augras‍ the link you provide return a 404 error