Skip to main content
Topic: EARLY Beta version of 2.0  (Read 3959 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

EARLY Beta version of 2.0

Time for a heads-up that we did an upgrade of the site today!  The last version the site was running on is the recommended production version 1.1.8   but this is our current 2.0 snapshot.  There is no install package for this, its a manual upgrade only and not recommended for real production sites AT ALL.  Franky its probably a bit early for this but we really need to get some testing and feedback going.

Now we're still fixing bugs and issues.  Some real and some just a result of the manual upgrade process.  As always you may need to do a hard refresh to clean out your browser cache as the theme files are completely new.  Once things settle a bit we will update the site to php8 as well.

Please report everything you still find so we can get to doing what we do best, creating more bugs ... The best place to report the issues is on our GitHub issues tracker  You can report them here, but that means someone else will have to add it to the tracker, which does not always happen so known bugs are simply overlooked.

Re: EARLY Beta version of 2.0

Reply #1

It's great to see Elkarte back up, Is there a list of changes for 2.0?

Re: EARLY Beta version of 2.0

Reply #2

Great news .
Thanks for the awesome work.

Re: EARLY Beta version of 2.0

Reply #3

Quote from: Allan – It's great to see Elkarte back up, Is there a list of changes for 2.0?
Not really, I can try to come up with something that users may care about.
There was a tremendous amount of restructure to the code, (as we did in 1.0 and somewhat in 1.1) which a typical user would not care about.

Re: EARLY Beta version of 2.0

Reply #4

One new item that folks can test is better emoji support. 

You can add all sorts of them:smile:to your post just by entering a : then the emoji name, like :smile as the simple example. 

There are 100's of available ones, currently the forum as over 1000 available.  They are all SVG icons so they scale up/down nicely and are crisp.  Once you enter the ':' and start to type in some text you will get a selection box of emoji that match .... some examples
:rolling_eyes: :airplane::elephant::abc::camera: :cat:You get the idea:wink:
Last Edit: January 02, 2022, 11:27:56 pm by Spuds

Re: EARLY Beta version of 2.0

Reply #5

:tada:

Was getting a little worried about y'all here.

Re: EARLY Beta version of 2.0

Reply #6

Thanks for bringing it back, I get a JSON error when liking your post @Spuds and the mention autocomplete doesn’t appear to work.

I’ll log them both on GitHub later

Re: EARLY Beta version of 2.0

Reply #7

Thanks for the report, and more so logging them:smile:I'm working on a quick (hope) fix PR to address some of these.

Re: EARLY Beta version of 2.0

Reply #8

Honestly - this is the best mobile theme I've ever used on a forum. I love it.

Re: EARLY Beta version of 2.0

Reply #9


Quote from: Spuds –
Quote from: Allan – It's great to see Elkarte back up, Is there a list of changes for 2.0?
Not really, I can try to come up with something that users may care about.
There was a tremendous amount of restructure to the code, (as we did in 1.0 and somewhat in 1.1) which a typical user would not care about.
That's fine no need then, sometimes major changes and this is just easier.  :wink:  (smiley worked  with adding : )

Re: EARLY Beta version of 2.0

Reply #10

Thank you for continuing to develop a new version of the engine ElkArte.
Community of forum owners on any forum engine (сообщество владельцев форумов на любом форумном движке) https://forumovod.ru

Re: EARLY Beta version of 2.0

Reply #11

Tried to like a post...

QuoteAn Error Has Occurred : SyntaxError: JSON.parse: unexpected character at line 2 column 2 of the JSON data

in the popup window, and the following as the POST response:

Code: [Select]
	<div id="fatal_error">
<h2 class="category_header">An Error Has Occurred</h2>
<div class="generic_list_wrapper">
<div class="errorbox" id="2" >Invalid argument supplied for foreach()</div>
</div>
</div>
<div class="centertext">
<a class="linkbutton" href="javascript:window.location.assign(document.referrer);">Back</a>
</div>

Re: EARLY Beta version of 2.0

Reply #12

I've tracked this one down:smile: 

The cause is do the 2.0 "conversion" and one table column not being updated to the new values.   It should be adding your like, its the member notification of that like that is causing the error.  I'll get this fixed tomorrow, need to test an update query first.

Re: EARLY Beta version of 2.0

Reply #13

Quote from: Trekkie101 – Honestly - this is the best mobile theme I've ever used on a forum. I love it.
Glad its working well!

2.0 did a fair amount of changing the existing CSS to Flex and Grid layouts to the frequently used areas.  That allowed a lot of crud/tricks/float/table/etc removal since (flex./grid) were designed to do what we need.  The goal (at least for me) on the beta was to have things look mostly the same, but with a new temp[ate/css structure behind it.  Its far from a template engine or anything like that, but a refactor of the old layout to current capabilities/standards.

Re: EARLY Beta version of 2.0

Reply #14

Cool! This will be awesome! Keep up the good work guys!

Another tidbit - this thread has a lot of overflow! The source seems to be the code box.