Skip to main content
Topic: EA versions and supported PHP versions (Read 777 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

EA versions and supported PHP versions

Somewhere I posted a suggestion in the course of some other topic regarding EA Versions and supported php versions, but of course I can't find it now..

The suggestion went along the lines of it being quite helpful to know the php versions that each EA version works with.. not just the earliest minimum, but the latest limit..

I recognize that it's hard to know before hand if a version will work with a php version that hasn't been released yet, that requires a very special kind of crystal ball.. but perhaps this thread can capture knowledge from EA admins when they discover that their version of EA no longer works with some new version of PHP..     which brings me to my question to start it off..


Does anyone know what version of PHP "breaks" EA v. 1.1.6?    8.0?  8.1?  None yet?

The reason I ask is that my site uses the php mail() function for a 'feature' that (I originally believed) had nothing to do with the EA Forum.. That function in my servers php  does not use an SMTP account, and lately, with SMTP verification protocols being required by most email servers, emails sent using the mail() function fail to go through, I presume at the moment it's because of the lack of the SMTP account verification.

 I'm in the middle of the resolution process (first I need to understand what exactly is going on, so I can evaluate options to resolve it), but the solution may well be that the mail server/system PHP version needs to be greater than the current 5.6 running on my host's system.  My own hosted server is running 7.2, with 7.4 being the latest option available, all of which are supposedly "depreciated" as well.

Once I accurately understand the current problem, one solution may be to go to a newer version of PHP (8.1?). And.... then the question becomes: "What does that break?"  If my current version of EA would be one of the victims, I may very well decide to go another route than using the native PHP mail() function instead. 
In other words, if a later version of PHP has an updated mail() function (and I don't know this either at the moment) that allows using an account login  (or some other scheme) to comply with the newest SMTP validation protocols (if that is indeed the problem), then I would want to know if switching to it requires upgrading EA as well (in addition to lots of other stuff I have running on the server), hopefully without having to set up a test server and resort to trial and error to find out., or just upgrading stuff until I "unbreak my 'production server" in order to resolve this issue  


Note: Let's not use this thread to deal with the mail() problem itself.. that's an entirely different topic and (hopefully) outside the scope of EA. It's just the latest issue I've encountered that has again raised this version-compatibility question. I'll resolve the mail() issue separately.



Anyway, knowing what versions of EA are compatible (or incompatible) with changes in the environment would be a handy thing to know, ya know?

If anyone has (or gets) that sort of knowledge, let's capture it here in this thread..  :kissing_heart:

Last Edit: May 21, 2023, 10:25:13 pm by Steeley

// Deep inside every dilemma lies a solution that involves explosives //

Re: EA versions and supported PHP versions

Reply #1

I'll give a partial answer as that is all I can really do !

1.1.6 is going back to far for me to remember ... I think this was for PHP 7.3 issues and all other etc. issues as reported
1.1.7 was aimed at php 7.4 .. should still run on 5.6.  This was a LARGE update
1.1.8 was aimed at php 8.0 .. should still run < php 7 Minor updates to address issues in 1.1.7
1.1.9 was aimed at php 8.1 .. will not run on < php 7 This was a LARGE update
1.1.10 ... pending to fix issues found with 1.1.9 and ones missed over time

Although PHP 7.4 is depreciated, I still run that on several sites.   TBH 7.x has been well tested, so 7.4 is really solid, especially when its your own server. So I know 1.1.9 runs fine on 7.4, as will 1.1.10

There were changes in 1.1.7 and 1.1.9 for PBE and some SMTP tweaks.  I use SMTP on my server to send email and that has been fine as long as you have all of the other email hoops set up ... DMARC, DKIM,  SPF, RDNS and a clean IP address.   Email requirements continue to get more difficult for the average SYSOP to achieve, but its still do-able.

 

Re: EA versions and supported PHP versions

Reply #2

That's a start Spuds....
Over time, hopefully we get input as sysops report things like "We upgraded to php X.y and now my EA v {whatever} looses {some significant functionality}.  There's a lot of that kind of info all over the forum here in "bug reports", etc. that really aren't "bugs" in the code, but compatibility issues with the environment they're running in, which requires an upgrade to a later (or for a new potential EA admin with an older server set up, an earlier) EA version to work right. 

(2.0 may not work well for someone stuck with a server running PHP 5.6, where v1.1.7 and earlier does? How does (s)he find that out besides posting up somewhere asking if anyone knows ... ? ) 

PHP isn't the only factor of course, DB type and its version are significant factors too (any EA versions compatible with HIVE? Or NOT compatible with Azure SQL?)

When we do discover an issue is indeed an environmental incompatibility, maybe recording that in this thread when we figured that out will build a quick reference as we go along.  Perhaps this topic should be changed to "Environmental (In?)compatibilities by EA Version" or something like that. At the risk of mission creep -maybe a Board with topics or sub-boards by version number where this compatibility stuff is captured for reference (after issues reported elsewhere - bug reports, support, etc. - are isolated in those boards , not for suspected issues to be reported and worked on in this reference board), would build a valuable resource . That discussion is above my paygrade however, although I wouldn't mind being part of that discussion - or the solution to make it work.. I'll post this idea up on  the Site Feedback board . 
Last Edit: May 20, 2023, 07:05:08 pm by Steeley

// Deep inside every dilemma lies a solution that involves explosives //