Skip to main content
Topic: Line break in activation email link (Read 332 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

 

Re: Line break in activation email link

Reply #1
that's caused by the email client, not the email itself
Be safe, Be kind, Happy Programing

Re: Line break in activation email link

Reply #2
that's caused by the email client, not the email itself

Wow Gmail's doing that? Must be an update on Gmail's part because it didn't happen in my previous Elkarte forums.

Rick

Re: Line break in activation email link

Reply #3
Well at least you know where to get it fixed then
Be safe, Be kind, Happy Programing


Re: Line break in activation email link

Reply #5
I did some quick testing on this and here is what I'm seeing with registration emails sent to:

Looking at the email on the native site (not an email client)
  • Yahoo -> link is intact
  • Outlook -> link is intact
  • ProtonMail -> link is intact
  • Gmail -> link is intact

All of the above email source have both the plain text and base64 encoded versions which is what the forum sends.

Looking at the emails with a client, in this case the Windows 10 Mail app
  • Yahoo -> link is intact,  the fetched email has been converted to quoted printable
  • Outlook -> link is intact, the fetched email has been converted to HTML from the plain text version
  • ProtonMail -> Did not test
  • Gmail -> link is broken, the fetched email has been converted to quoted printable

So it seems when the email client requests the email from Gmail, and Gmail converts it to QP encoding, something goes "wrong".  As to why its a dunno at this point, I hope Sundar gives you some insite.
Be safe, Be kind, Happy Programing