Skip to main content
Topic: Which PHP version to use with Elkarte 1.1.9? (Read 557 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Which PHP version to use with Elkarte 1.1.9?

I finally got some time to update my forum to Elkarte 1.1.9 and PHP 8.1 and everything seems to work fine for now. The elkarte error log is empty and that's somehow strange :cheesy: 
I am wondering, which is the recommended PHP version to use with Elkarte 1.1.9? 8.1 or 8.2?
sorry for my bad english

Re: Which PHP version to use with Elkarte 1.1.9?

Reply #1

I think it still is php 7+, so 7.4 is my preferred php for 1.1.9. Of course with all the patches, 8.1 or 8.2 could work fine too but I always thought php 8+ is mainly aimed for EA 2.0 and above.
Last Edit: March 15, 2023, 09:05:22 pm by ahrasis

Re: Which PHP version to use with Elkarte 1.1.9?

Reply #2

Some add ons don't play well with versions 8.x. 

Re: Which PHP version to use with Elkarte 1.1.9?

Reply #3

Thanks for your answers.
Since yesterday I am running PHP 8.1 on my both forums, and for now no errors in elk log and also not a single report from my members. I think I will keep this "experimental" setup and report future or possible bugs.
With PHP 8.2 I noticed some errors from ReCaptcha add-on.
sorry for my bad english

Re: Which PHP version to use with Elkarte 1.1.9?

Reply #4

Quote from: radu81 – I think I will keep this "experimental" setup and report future or possible bugs.
:rolleyes:  I'm afraid I've talked too early and...
Quote from: badmonkey – Some add ons don't play well with versions 8.x.
you are right, for now I've found something with Elkarte Prefix add-on which I'll report on the dedicated topic
sorry for my bad english

 

Re: Which PHP version to use with Elkarte 1.1.9?

Reply #5

ElkArte core should be fine with 8.1 or 8.2, that is what I did all my update work on.  I do not know of any incompatibilities knock on:wood:

I updated all my addons (at least I hope) to support 8.1 etc. BUT as noted by @badmonkey there are addons that have not kept up with PHP changes.  Best to report those as getting things updated for 8.x is important as 7.4 got its last set of patches in Dec/2022 and is now at support EOL.