Skip to main content
Topic: Class 'MessageTopicIcons' not found (Read 316 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Class 'MessageTopicIcons' not found

Went to make my first post and got Class 'MessageTopicIcons' not found

Please don't tell me I need to reinstall this.

Rick

Re: Class 'MessageTopicIcons' not found

Reply #1

Thats odd ..... I'd start with making sure the file exists and that the directory is accessible

For 1.1 the file will be MessageTopicIcons.class.php and it will be in your \sources\subs directory

Re: Class 'MessageTopicIcons' not found

Reply #2

MessageTopicIcons.class.php does exist. Is the file supposed to be empty?

Running 1.1.8

Rick

Re: Class 'MessageTopicIcons' not found

Reply #3

That's good ... and I presume the directory/file permission are all in order.  Do you have any error entries in you forum log or the server log?  Also what PHP version are you running?

Re: Class 'MessageTopicIcons' not found

Reply #4

Quote from: Spuds – That's good ... and I presume the directory/file permission are all in order.  Do you have any error entries in you forum log or the server log?  Also what PHP version are you running?

I'll check those other things later but I can tell you I was running PHP 8.0 or 8.1 then I switched to 7.4 after installation

Re: Class 'MessageTopicIcons' not found

Reply #5

I decided to reinstall under PHP 7.4. Working fine now. Thank you for your help.

Rick

Re: Class 'MessageTopicIcons' not found

Reply #6

Glad you got it sorted ... I could have been an 8.1 thing, I do not think all the 8.1 "fixes" are in 1.1.x (yet)