Skip to main content
New "Version Compatibility" ref board? Started by Steeley · · Read 5326 times 0 Members and 1 Guest are viewing this topic. previous topic - next topic

New "Version Compatibility" ref board?

The old expression "Incompatibility is just an upgrade away" is becoming more and more evident every day. An upgrade on the internet or server and suddenly some  ElkArt forum operation breaks. A forum error is reported as a bug or on the support board, and after being "trouble-shot" is isolated to something indeed in the environment that is no longer compatible with the EA version running. It's not a bug in the code, but may drive a code patch or version update to address.

There's a lot of that kind of info scattered all over the forum that requires an upgrade to a later (or for a new potential EA admin with an older server set up, an earlier) EA version to work right.

(For example, 2.0 may not work well for someone stuck with a server running PHP 5.6, where v1.1.7 and earlier does? How does (s)he find that out besides posting up somewhere asking if anyone knows ... ? )

PHP version, DB type and its version are significant environmental dependencies, but also changes in the internet Email security/Spam functions and servers can suddenly render an EA version "non-functional" in a significant way.
 
When we do discover an issue is indeed an environmental incompatibility, having a separate board (perhaps with sub boards of specific versions) to capture and list those discoveries would be a valuable resource and reference.  It wouldn't be for reporting and resolving issues, but for capturing the identified incompatibility and maybe linking to patches or workarounds (if any) for that version's reported incompatibility.

If that sounds like a nifty idea, I'd be remiss if I were to suggest something for other people to do, so I'm willing to participate in discussing architecture and procedure for that kind of board, and since I'm retired and have nothing to do but make dinner and screw-around with stuff (including my own forum and websites), I'm willing to even assist in its operation if desired.
Last Edit: May 20, 2023, 07:43:19 pm by Steeley

// Deep inside every dilemma lies a solution that involves explosives //