Skip to main content
Board icons not changing? Started by Jorin · · Read 11790 times 0 Members and 1 Guest are viewing this topic. previous topic - next topic

Board icons not changing?

Sunday morning, my head aches. It seems not possible today to change my board icons. Don't laugh at me!  :D

I made a copy of the default theme to work with and named it "fairflixxt_blue". I chose this in my profile. I changed the file board_icons.png. Then I cleared the cache of my chrome browser, but I didn't see my changes. Then I cleared the cache of my forum. No changes. Then I used IE, which never had seen the site before. My changes aren't there also. Then I chose the new theme as forum default with variant "ElkArte Light" and set everyone to it: No changes. I am in the right folder on my server (hope so: "themes/fairflixxt_blue/images/_light). Or not?

What do I wrong? Where are my changes?  :o

Re: Board icons not changing?

Reply #1

this is an example with images:

.category_boards .board_icon, .board_key:before {
background-repeat: no-repeat;
background-image: url(../../images/_myvariant/board_icons.png);

1) disable CSS + Javascript minify (admin - Options - General).
2) disable server side caching (admin - server settings... )
3) refrsh the browser cache

Last Edit: February 23, 2014, 03:45:44 am by TE
Thorsten "TE" Eurich
------------------------

Re: Board icons not changing?

Reply #2

Thanks. Never thought about that this must be changed in the css file first.  :o

Re: Board icons not changing?

Reply #3

Quote from: TE – .category_boards .board_icon, .board_key:before {
background-repeat: no-repeat;
background-image: url(../../images/_myvariant/board_icons.png);

Hm... This must be in index.css?

I don't get it. :(

Re: Board icons not changing?

Reply #4

It's in /themes/{your_theme}/css/_{your_variant}/index_{your_variant}.css

For example for the Be Social! Variant it's in:
/themes/default/_besocial/index._besocial.css

Yup, a bit deeper into the structure.

A bit of explanation: in order to hopefully simplify the way the theme is structured Ant and TE separated the "structure" form the "appearance". So if you want to (let's say) move an element you look into the usual index.css, instead if you want to change its color (or borders, or other similar things) you look into the variant's css (the one I suggested above).
Of course if you prefer to have everything in one place you can put everything together. ;)
Bugs creator.
Features destroyer.
Template killer.

Re: Board icons not changing?

Reply #5

Now I got it! Thank you very much! I had none of these files because I made a copy of the default theme via admin center. I created the neccessary files and now it works! Been working on a blue variation for a hour now, looks great!  :)

Just one little problem: When you move the mouse over a posters name in a topic, the color of the name changes. I can't find the place in the css file.

Re: Board icons not changing?

Reply #6

That means some important files are not copied over when creating a new theme... this is bad (and a bug of course!).
Bugs creator.
Features destroyer.
Template killer.

Re: Board icons not changing?

Reply #7

Seems so.  :(

Re: Board icons not changing?

Reply #8

Tracked here as blocker:
https://github.com/elkarte/Elkarte/issues/1426
Bugs creator.
Features destroyer.
Template killer.