Skip to main content
Topic: ElkArte 1.1.9 - Release Announcement (Read 1172 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

ElkArte 1.1.9 - Release Announcement

Today, we are pleased to release ElkArte 1.1.9. This is the 10th release in the 1.1 line.

This release addresses any remaining compatibility issues with PHP 8.1.  In addition to full PHP 8.x support, bugs were identified and fixed, enhancements to existing functionality was added and a several new features were included.  Overall this is a large update intended to bridge the gap between the 1.1 and upcoming 2.0 line.

Of course you are encouraged to update to this release since it contains a lot of fixes and improvements, thank you for your continued support!

New Features and Enhancements
  • Quick Quote allows you to select text in a post and quote just that selection when making a reply.
  • Quote Show More is a quote display limiting function.  Should someone quote a long post, only a portion is shown unless the users selects the "show more" text that is overlayed on the quote.  This length is configurable in the admin panel.
  • Webp support for attachments and avatars.
  • Open graph meta data and schema.org micro data, to help with SEO, is generated and inserted in the page output.
  • Nested Quote Depth level vs previous behavior of yes/no.
  • Save avatars as and thumbs as PNG option has been removed.  The system will now detect if the image has transparency and save as appropriate (Webp or if not enabled then PNG or JPG)

Refer to the release notes on the forum for a complete list of updates. Release Notes

:high_brightness:If you were running any beta 1.1.9 patches you should uninstall those and install this final package.
 

Patching procedure:
  • Go to the page https://github.com/elkarte/Elkarte/releases/tag/v1.1.9
  • Download the file ElkArte_v1-1-9_patch.zip to your computer
  • Go to your forum: Admin > Main > Package Manager > Upload Package
  • Click the button to upload the package
  • Locate and select the file you downloaded at point 2
  • Click the "upload" button
  • Follow the instructions on the screen.


Upgrading procedure:
  • If you are running a previous 1.1 version then you have two options
    • Install each of the patch files in sequence until you get patched to 1.1.9
    • Or you can use the full install package and overwrite your existing files,  then run the updater yourforum/install/update.php (which should come up automatically).  If you choose to use the full package it is strongly advised to uninstall any addons, do your upgrade, then reinstall the most recent version of the addons.

:high_brightness:Be sure to check for updates to any addons you are running, many have been updated to support new 1.1.9 features.

For any question you may have, feel free to ask on the support forum.

Re: ElkArte 1.1.9 - Release Announcement

Reply #1

Once again, you da man spuds. Thanks for all your hard work!

Re: ElkArte 1.1.9 - Release Announcement

Reply #2

Thanks for your hard work and for your time! :partying_face  :partying_face 
sorry for my bad english

Re: ElkArte 1.1.9 - Release Announcement

Reply #3

Oh yea...
yes-baby.gif

// Deep inside every dilemma lies a solution that involves explosives //


Re: ElkArte 1.1.9 - Release Announcement

Reply #5

Thanks @Spuds. You are awesome.

Re: ElkArte 1.1.9 - Release Announcement

Reply #6

A great thanks @Spuds  !
There are some new translations : i will try to do the job for the french one.

Re: ElkArte 1.1.9 - Release Announcement

Reply #7

Thanks dear friend, I've happily updated my forum