ElkArte Community

Extending Elk => Localization => Topic started by: phantom on June 07, 2014, 10:54:41 pm

Title: Strings missing
Post by: phantom on June 07, 2014, 10:54:41 pm
File Profile.english.php:
There is this line that cannot be translated, because it's missing from transifex index:
Code: [Select]
$txt['password_success'] = 'Your password was changed successfully.<br /><a href="' . $scripturl . '?action=login">Click here to login</a>.';

Issue is when translation contains ElkArte variable, $context, $scripturl etc.
Downloaded file has 446 lines, but transifex sees only 437 lines.
Title: Re: Strings missing
Post by: emanuele on June 08, 2014, 06:22:12 pm
In case there is no way to tell transifex to use concatenations, I see two options:
1) do the translations off-line and hope transifex is able to understand the files once pushed,
2) https://github.com/emanuele45/Dialogo/compare/avoid_concat (not yet finished). <= now is completed.

Option one is a guess, option two is a pain (but, TBH, is a pain that sooner or later we will have to face no matter what: text strings should not contain php concatenations, so at some point we'll have to get rid of them all).

In the meantime, I'll try option one to see if it works.
But for the "final" solution, up to you guys. Let me know. ;D
Title: Re: Strings missing
Post by: emanuele on June 10, 2014, 03:41:04 pm
Okay, the strings have been updated in the github repository.
I think @TE is pushing the files manually, am I right?
If so let's give him time to upload the new files.
Title: Re: Strings missing
Post by: TE on June 10, 2014, 09:04:33 pm
I think @TE is pushing the files manually, am I right?
Nope, the files have the auto-update feature from Transifex enabled.... They are updated from time to time, not sure about the interval though... However we could use the API to enforce the file updates..
Title: Re: Strings missing
Post by: emanuele on June 10, 2014, 11:28:17 pm
Ohh... okay! LOL
Title: Re: Strings missing
Post by: phantom on June 14, 2014, 09:33:13 pm
In language editor index.english.php is missing key admin_maintenance_active and admin_session_active
Code: [Select]
$txt['admin_session_active'] = 'You have an active admin session in place. We recommend to <strong><a class="strong" href="%1$s">end this session</a></strong> once you have finished your administrative tasks.';

$txt['admin_maintenance_active'] = 'Your forum is currently in maintenance mode, only admins can log in.  Remember to <strong><a class="strong" href="%1$s">exit maintenance</a></strong> once you have finished your administrative tasks.';


But  I think that I already translated this two strings...

//edit:
Now I see that more strings are not in Transifex editor... I'm going to wait for RC and translate all files manually...
Title: Re: Strings missing
Post by: emanuele on June 14, 2014, 10:01:47 pm
The new untranslated strings are due to the recent changes that brought back all those not visible before.
No strings were added recently.
Title: Re: Strings missing
Post by: phantom on June 14, 2014, 10:14:17 pm
No strings were added recently.
I know that.

But I'm sure that i translated those and few more and now when file is downloaded this is not translated. 
Another example: template_parse_error_details:
(https://www.elkarte.net/community/imagecache.php?image=http%3A%2F%2Fi.imgur.com%2F66WHDI4.png&hash=145d877c25f5742e5dde9562d9f743dd" rel="cached" data-warn="External image, click here to view original" data-url="http://i.imgur.com/66WHDI4.png)

As you can see key is translated (3 days ago), but here (in file from today) it's not:
(https://www.elkarte.net/community/imagecache.php?image=http%3A%2F%2Fi.imgur.com%2Fp9d2X0o.png&hash=f9e6242d08aeca999fd4bcad86cbfc3a" rel="cached" data-warn="External image, click here to view original" data-url="http://i.imgur.com/p9d2X0o.png)
Title: Re: Strings missing
Post by: emanuele on June 14, 2014, 11:08:04 pm
Ahhh... you mean here at http://translations.elkarte.net/ ?

I feel the cronjob is not running properly, the timestamp of the files is a week old (6/6/2014).
Maybe @TE can check if something is wrong somewhere around the tx pull time. O:-)
Title: Re: Strings missing
Post by: phantom on June 15, 2014, 01:00:07 pm
That would explain it ::)

OT: But still TF has few issues that are annoying (for example, translation needs to have the same number of parentheses which is impossible in some cases..)
Title: Re: Strings missing
Post by: emanuele on June 15, 2014, 01:13:41 pm
Can you provide with an example?
There are several ways to fix things, and if TX is not the best tool for translation it may be worth explore other solutions.
Title: Re: Strings missing
Post by: emanuele on June 15, 2014, 01:24:50 pm
A little "ETA" worth a second post.

As a general note, those like you that work with translations are the best to provide ideas and/or fixes for language strings and localization procedures.

Bring up any problem you are facing is the most important step in order to find a solution, because without knowing that a problem exists to begin with nobody can "fix" it in any way.

Then, if you have any suggestion for either provide a better translation/localization framework, or improve the original language strings, of course these are of great help, again because you are the people that read strings the most, I for one, working on the code I just read the indexes, I don't know how most of the strings appear in English. I see them when I do translations in Italian, and then I can see if there is a problem, any kind of problem, it may be a string that is difficult to translate, a string that is ambiguous, a string that may require tricks or adjustments and so on.
Really, the language the script will talk depends a lot on your work, and not only for the language you know best, but for all of them, including English. ;D
Title: Re: Strings missing
Post by: phantom on June 15, 2014, 06:04:59 pm
Can you provide with an example?
There are several ways to fix things, and if TX is not the best tool for translation it may be worth explore other solutions.
well... dont know why or how but now translation can be approved... must be some glitch in TF.
Title: Re: Strings missing
Post by: TE on June 16, 2014, 08:46:12 am
Maybe @TE can check if something is wrong somewhere around the tx pull time. O:-)
Edited the cron job again, hopefully it fixes the issue..
Title: Re: Strings missing
Post by: phantom on July 02, 2014, 10:16:46 pm
Unfortunately it didnt fixed it :|

EmailTemplates was updated by me 3 days ago, and it is 100% completed.

Key forgot_password_body and activate_reactivate_body and few others are still in English in package downloaded few minutes ago.
Title: Re: Strings missing
Post by: Spuds on July 02, 2014, 11:23:16 pm
@TE if you get some spare time could you take another look at this  O:-)

Thanks!
Title: Re: Strings missing
Post by: Jorin on July 03, 2014, 05:43:22 pm
It seems I better wait while this problem is fixed before I invest more time in the german language files?

edit: Where can I find the latest, actual english language files please?
Title: Re: Strings missing
Post by: phantom on July 06, 2014, 06:00:05 pm
my guess - on github => https://github.com/elkarte/Elkarte/tree/master/themes/default/languages/english