ElkArte Community

Elk Development => Bug Reports => Exterminated Bugs => Topic started by: txcas on February 13, 2016, 08:21:20 pm

Title: Missing png files under default theme
Post by: txcas on February 13, 2016, 08:21:20 pm
I noticed that the icon to the left of some posts was missing.  I looks like we are missing the following files under themes\default\images\post:
android.png
iphone.png
tablet.png
Title: Re: Missing png files under default theme
Post by: TE on February 13, 2016, 08:47:57 pm
Not ElkArte files by default... That's a bug with the wedge importer instead.
Title: Re: Missing png files under default theme
Post by: txcas on February 13, 2016, 09:49:04 pm
Thanks. I will try to find those references in the database and change them to the default message icon.
Title: Re: Missing png files under default theme
Post by: Burke Knight on February 13, 2016, 11:38:54 pm
Would be easier to just add them.
You can go in and do custom message icons, and see them there.
In the old forum's message icon directory, just copy them to the default theme's in the ElkArte Forum.
Title: Re: Missing png files under default theme
Post by: txcas on February 14, 2016, 12:06:35 am
True I could create icons, but I know more SQL than graphics design.  Since ElkArte is not detecting iphone vs. android vs. tablet, I fixed the problem in the database.  Here is an example of the query I used just in case someone else runs into this:

Code: [Select]
update elkarte_messages
set icon='xx'
where icon='iphone'

That changed all the missing iphone icons to the default xx icon. Replace iphone with android or tablet to fix the other missing icons.