ElkArte Community

Extending Elk => Localization => Topic started by: EricG on February 02, 2017, 12:29:48 am

Title: Why can't I change the default language ?
Post by: EricG on February 02, 2017, 12:29:48 am
Hello,

I've installed french.   It works when I change the language value in a user account

But I can't change the default language : when I edit it and save,    it doesn't work !!! It reverts to english !!!

what's up ???

Title: Re: Why can't I change the default language ?
Post by: emanuele on February 02, 2017, 01:20:50 am
Hi and welcome. :)

hmm...
Just to explain a possible case, not sure it is the one you are facing. :)
If you change the language in your profile, that takes precedence over the global setting (and IIRC save the profile page counts as "change the language").
Instead, if you are talking about guests... could you try with an incognito window, just to be sure it's not some cookie leftover?
Title: Re: Why can't I change the default language ?
Post by: EricG on February 02, 2017, 11:16:05 am
Well, I've juste tried that.  It doesn't work either

  :(
Title: Re: Why can't I change the default language ?
Post by: Spuds on February 02, 2017, 04:32:54 pm
I have not been able to reproduce this (yet) on 1.0.9

I installed French via the package manager.

Went to Admin->Configuration->Languages and selected French as the default and then Save.   I tried this both from the  Edit Language and Settings tab (as you can choose the default language in either place), and both worked as expected. 
Title: Re: Why can't I change the default language ?
Post by: Spuds on February 02, 2017, 05:39:30 pm
One other thought is that I believe the default language is saved/added to your Settings.php file in your forums root directory. 

If for some reason you don't have write access to that file it would not be able to "save" your choice ... I thought the site gave a warning when that file is not writable but ??
Title: Re: Why can't I change the default language ?
Post by: EricG on February 02, 2017, 07:42:13 pm
I installed Elkarte on another web host. I could easily put French by default on the new host. So, I think it comes from rights on the Setting.php file.
Another solution would be to directly modify this file and return it via FTP I think.

Never mind, I'm going to use the other web host anyway !

 ;)