ElkArte Community

Project Support => General ElkArte discussions => Topic started by: emanuele on June 02, 2019, 10:46:56 pm

Title: Testing 1.1.6
Post by: emanuele on June 02, 2019, 10:46:56 pm
Hi all!

I prepared the patch for 1.1.6, as usual, I'd like to ask for your help in testing it.
Tests needed: install/uninstall on a clean env.
Likely there is something broken, so... use it only if you are somehow confident in what you are doing.
Hopefully it will install fine (I think I remembered all the pieces to tweak, but who knows), worst case you'll get some errors already during install.
Please report them. :)
Title: Re: Testing 1.1.6
Post by: Spuds on June 04, 2019, 03:52:12 pm
Seems to be a couple of issues with the package, looks like its has some duplicate 1.1.5 changes which of course give the test error. 

I've made some adjustments and attached a new file.  I have NOT yet done the file compare after running this on 1.1.5  to make sure it matches the 1.1.6  repo to make sure nothing was missed.
Title: Re: Testing 1.1.6
Post by: Spuds on June 06, 2019, 12:53:38 am
I did a diff on that patch and whats in the patch_1-1-6 branch and they seemed to match, so I think its correct.  Need feedback from others if it works for them and any errors encountered.
Title: Re: Testing 1.1.6
Post by: radu81 on June 07, 2019, 09:59:54 pm
Thank you for supporting Elkarte!
I just upload the package published by Spuds on a test forum and install it without errors. I don't have much free time and did not tested well, but is something that I should check with this update?
Title: Re: Testing 1.1.6
Post by: Spuds on June 07, 2019, 10:26:38 pm
Mainly just testing that it installs correctly ,,, you know the drill with different server configs, sometimes things go a bit sideways.
Title: Re: Testing 1.1.6
Post by: emanuele on July 14, 2019, 10:50:43 pm
Here it is the latest package.
Application produces a perfectly identical install as a brand new 1.1.6 so it should be fine.

I'll push it to github tomorrow evening... today I have to go bed.
Title: Re: Testing 1.1.6
Post by: Spuds on July 14, 2019, 11:58:02 pm
"perfectly identical" now that is the Awesome Sauce !
Title: Re: Testing 1.1.6
Post by: radu81 on July 16, 2019, 09:29:29 am
Just install it on a test forum and switched to PHP 7.3, no errors in elk log until now. ;)
Title: Re: Testing 1.1.6
Post by: emanuele on July 16, 2019, 06:15:29 pm
"perfectly identical" now that is the Awesome Sauce !
Weeeell, you know I like to emphasize things. :P
Title: Re: Testing 1.1.6
Post by: kucing on July 18, 2019, 01:55:58 am
so when it be released officially? or should install that attached patch?
Title: Re: Testing 1.1.6
Post by: radu81 on July 18, 2019, 02:02:07 pm
I'll wait for the official patch 
Title: Re: Testing 1.1.6
Post by: Jason on July 21, 2019, 10:25:43 am
Should it need more testing and feedback to fix the issue. If so I will download and test it.
Title: Re: Testing 1.1.6
Post by: emanuele on July 21, 2019, 11:39:10 pm
The more testing the better.
I know what I have tested and you will get as much. If there are problems that I did not find, then that will require to be fixed later.