ElkArte Community

Project Support => Support => Topic started by: Auctor Lucan on October 11, 2019, 04:00:38 pm

Title: Deprecated Error, please help?
Post by: Auctor Lucan on October 11, 2019, 04:00:38 pm
Hi there!

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; PasswordHash has a deprecated constructor in /customers/6/a/e/uss-theurgy.com/httpd.www/forum/sources/ext/PasswordHash.php on line 27

That's the message I get on my forum when running PHP 7.2 on Elkarte 1.0.10. I cannot upgrade to 1.1 because of the theme and my crucial addons not being supported by Elkarte 1.1  To make matters worse, my provider forces PHP upgrades, and this Deprecated error will eventually become a real issue when upgrading to PHP 7.3 . Can anyone help me fix this while still using 1.0.10 ?

Thanks in advance!

Best,

Auctor Lucan
Title: Re: Deprecated Error, please help?
Post by: Spuds on October 11, 2019, 09:12:55 pm
That is odd .... we updated for that in the 1.0.10 release so at least that 7.x issue was fixed.  Use the attached file, simply replace the one that is in your sources/ext directory.

You are probably going to find other 7.2 issues running 1.0.10, but I fully understand the pain associated with theme updates etc ... which addons are not yet 1.1?

Title: Re: Deprecated Error, please help?
Post by: ahrasis on October 12, 2019, 04:45:29 am
As far as I remember this error is common in 1.0.10 as it is not fully compatible with php7. It is best to upgrade to latest 1.1 branch.