Skip to main content
Topic: Problem with admin access (Read 5828 times) previous topic - next topic - Topic derived from ElkArte 1.0 beta 2 - ...
0 Members and 1 Guest are viewing this topic.

Re: Problem with admin access

Reply #15
Have you tried changing the password via the profile page? Could help as well..
Thorsten "TE" Eurich
------------------------

Re: Problem with admin access

Reply #16
Sorry for the split, it's not because I want to keep the release notes clean, more to keep a bit of organization. ;)

So @kucing, to recap a bit:
* you migrated from SMF 2.0.6,
* you updated to Elk 1.0 Beta 1,
* then you updated to beta 2.
Once on beta 2 you are not able to access the admin panel.

What I would check is, in the database, does your password begin with the following string?
Code: [Select]
$2a$10$
If the answer is yes, then your password has been successfully migrated to the new system and that is nice. If not then your password is still the old one.
Just for a test, try to:
* logout,
* clean your browser's cache,
* reload the page, <= very important
* login again.
It may be some javascript file was cached by your browser and not replaced with the new ones.

If this doesn't work, let's try to narrow down the possibilities: try to disable javascript in your browser and see if you can login.

Thank you very much for you patience with this! ;D

IIRC the passwrd column was varchar(32) before the password change and needs to be varchar(64)..
AFAIR it was already a varchar(64) since SMF's times.
Bugs creator.
Features destroyer.
Template killer.

Re: Problem with admin access

Reply #17
Quote
AFAIR it was already a varchar(64) since SMF's times.
I believe that is correct, and I'd assume that was due to supporting migrations from other systems some of which used sha256 which is 64 ... Our new ones are "some" length, but will always fit in the 64 varchar.

Not being able to get in to the admin area, but being able to log on is very strange  ???

Be safe, Be kind, Happy Programing

Re: Problem with admin access

Reply #18
Will try all the suggestions, stay tuned for the updates. :)

Edit:
It already converted to new password system.

Looks like it's cache problem, I tried with JavaScript disabled and it successfully let me in to Administration Center. Sorry for all the confusion.

Thanks!

Edit2:
I cleared all my browsing history, cache, whatever can be cleaned in Chrome and Internet Explorer but still cannot enter the administration center if JavaScript enabled.

will try to clear elkarte cache now.

Edit3:
Yup, elkarte cache is the problem. cleared and now can login to administration center. :D

Re: Problem with admin access

Reply #19
that's odd, the upgrade should use a clean_cache() at some point.. ?!°?
I''m glad the problem is solved :)
Thorsten "TE" Eurich
------------------------

Re: Problem with admin access

Reply #20
Great!
Now we have something to work on.

I suspect you are using the javascript and css minifier, correct?
Bugs creator.
Features destroyer.
Template killer.

Re: Problem with admin access

Reply #21
yes, I enabled level 1 cache (file based).

Re: Problem with admin access

Reply #22
Nope, those are two different things: one is the cache, another one is the "css and javascript minify".
If you go to: amin > configuration > features and options > general
there is an entry named "Minify Javascript and CSS files". Is it checked or not?
Bugs creator.
Features destroyer.
Template killer.

Re: Problem with admin access

Reply #23
ah sorry, I forgot where is the location of minify setting so I though that caching is doing the same like W3TC for WordPress. Yes, I checked minify.


Re: Problem with admin access

Reply #25
That one should be fixed now.
Bugs creator.
Features destroyer.
Template killer.