Skip to main content
Topic: Censor issue - 8: Undefined index: allow_no_censored (Read 1459 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Censor issue - 8: Undefined index: allow_no_censored

Below error in the error log ..

8: Undefined index: allow_no_censored

File is /sources/load.php on line 2398


Appears to be caused only by the Admin account. The regular member account does not produce the error when making a post. None of the posts have any slur words at all in them.

The master.zip files were uploaded to the test site this evening.

Re: Censor issue - 8: Undefined index: allow_no_censored

Reply #1
I didn't check the code (yet), but I suspect this is generated by a new setting added recently. It shouldn't happen in a new install or running an upgrade...
Yeah, I know I keep repeating that run upgrade.php is not needed... I'm a liar! No, not entirely, it can be fixed even only by saving the setting in the admin page (at the moment I don't remember where that page is and I don't have an install handy... :-[).
Will come back in the afternoon/evening.
Bugs creator.
Features destroyer.
Template killer.

Re: Censor issue - 8: Undefined index: allow_no_censored

Reply #2
 :)  No problem. The one option I know of is in the user profile, enable/disable censoring. The problem occurs regardless of the option setting.

Also, the Session Verification fails have returned.

Re: Censor issue - 8: Undefined index: allow_no_censored

Reply #3
Well ... it may not be a bug. I FTP'd into the server and deleted the cache that way and the problem does not reappear. I had deleted the cache last night via Admin panel and that did not help. << shrug >> 

Re: Censor issue - 8: Undefined index: allow_no_censored

Reply #4
hmm... the fact the cache is not deleted may be a problem of permissions? (Guessing.)
It may be worth adding an is_writable check when showing the task button (clean cache).
Bugs creator.
Features destroyer.
Template killer.