Skip to main content
Topic: [ADDON] SimplePortal (Read 56804 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: [ADDON] SimplePortal

Reply #465
@Auctor Lucan‍ I merged here your topic since it's related to Sportal

I've seen this error too, but I don't remeber how I solved. If you just updated from elkarte 1.0 to 1.1 try to open and save all blocks and/or disable/enable them. Try also enable/disable the portal from SP settings.

Also check that you are using the latest version https://github.com/SimplePortal/SimplePortal_ElkArte/archive/development.zip
sorry for my bad english

Re: [ADDON] SimplePortal

Reply #466
Hello people from ElkArte :)

I just upgraded my SP version to the one linked above and I'm currently facing two issues:

1) The "New post" icon appears when somebody already read that post. When a post is actually unread, SP shows no icon at all. This issue was there even with the previous version.

2) Right side blocks show under the top or bottom ones. This is a new problem I didn't have with the previous version.

Re: [ADDON] SimplePortal

Reply #467
I'm not sure I understand the first issue, is that inside of one of SP blocks?

I believe I set it up so the right side will "float" under the other blocks when the screen narrows, what happens when you use a full screen on your browser?
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: [ADDON] SimplePortal

Reply #468
I'm not sure I understand the first issue, is that inside of one of SP blocks?
Anytime I have an issue I always forget to specify something. Always. Sorry >_>
Yes. It's the Recent Post/Topic block, with Posts and Full options enabled.

I believe I set it up so the right side will "float" under the other blocks when the screen narrows, what happens when you use a full screen on your browser?
The Recent Posts/Topics block from above is the one I'm using in the Top Blocks position. If I add a Right Side Block, this one goes under the Recent Topics block if I'm full screen. By switching to a little window it goes under all the others on the left.
It happens even if I put the Recent Posts block in Bottom position instead of Top.

Re: [ADDON] SimplePortal

Reply #469
Thanks for the clarification, let me see if I can reproduce the error.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: [ADDON] SimplePortal

Reply #470
Thanks again for all your hard work Spuds!  I'm testing this on a low traffic production site before going to the larger ones.

One item encountered is an int expected database error. In subs/PortalArticle.subs.php, changing

Code: [Select]
$request = $db->query('', '
SELECT
views, comments
FROM {db_prefix}sp_articles
WHERE id_article = {int:article_id}
$query[] = 'spa.id_article = {int:article_id}';
$parameters['article_id'] = (int) $article_id;
}

to

Code: [Select]
$request = $db->query('', '
SELECT
views, comments
FROM {db_prefix}sp_articles
WHERE id_article = {string:article_id}
$query[] = 'spa.id_article = {int:article_id}';
$parameters['article_id'] = (int) $article_id;
}

"seems" to fix it. Is that a proper fix?

Also, I'm having issues inlining attached images in articles. Is there a means to do so? Edit: they work fine for images attached in forum threads, or hosted elsewhere. They don't work for images attached to the article itself.  

Is there a way to give blocks custom styling (i.e. no background at all)?  Nevermind, figured out it's as easy as creating a custom style profile!  ;D

Some blocks are hidden on mobile, at least in Chrome. Is there a way to remedy?

Sorry for the million questions. Thanks again!  8)

Re: [ADDON] SimplePortal

Reply #471
I need to look into a couple of those items ... which package did you install?  I want to make sure I'm looking at the right stuff.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.


Re: [ADDON] SimplePortal

Reply #473
Dang, that would be the latest ... Need to see what I missed adding from my local
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.


 

Re: [ADDON] SimplePortal

Reply #475
Where can I download the translation of files into Italian SPortalAdmin and SPortalhelp for version 1.0.0.rc1?
Thank you
Saluti
Sebastiano Basile