Skip to main content
Topic: [ADDON][beta] Topic Prefix (Read 17174 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: [ADDON][beta] Topic Prefix

Reply #30
If you download the "master" from github (the green button "clone or download" here and then "download") should have all that admin panel.
I just tried that but I still see the old version

edit: it was not a clean install, I uninstalled the old version, I removed the old package and installed the new version
sorry for my bad english


 

Re: [ADDON][beta] Topic Prefix

Reply #32
This is an addon I have overlooked. I vote for this as a feature too.


Re: [ADDON][beta] Topic Prefix

Reply #34
I installed the add-on on Elkarte 1.1 using the emulating mode, but when I go to ACP -> Post and topic -> Prefixes I get this error:



In error logs of elkarte I see:

Code: [Select]
Type of error: General
Warning: filemtime(): stat failed for /themes/default/scripts/TopicPrefix.js
http://test.sss.ovh/skoda/index.php?action=admin;area=postsettings;sa=prefix;S8pcnEv=gZotfnpY7AtFRo6iANOV9aBvpMFwjjL2
File: /sources/SiteCombiner.class.php
Line: 348
sorry for my bad english


Re: [ADDON][beta] Topic Prefix

Reply #36
Code: [Select]
Type of error: General
Warning: filemtime(): stat failed for /themes/default/scripts/TopicPrefix.js
http://test.sss.ovh/skoda/index.php?action=admin;area=postsettings;sa=prefix;S8pcnEv=gZotfnpY7AtFRo6iANOV9aBvpMFwjjL2
File: /sources/SiteCombiner.class.php
Line: 348

Ohh... that's easy: I forgot to put the TopicPrefix.js file in the package-info.xml and so it's not copied into the theme. O:-)
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON][beta] Topic Prefix

Reply #37
Ok, downloaded the .js file from github and uploaded to themes/default/js and I am able to access the Prefixes in ACP. I am able to add prefixes and assign them to a board, but if I edit a topic and assign a prefix I get this error:

count(): Parameter must be an array or an object that implements Countable

In elkarte logs I have 2 errors:
Code: [Select]
Type of error: General
Warning: count(): Parameter must be an array or an object that implements Countable
File: sources/subs/TopicPrefixTcCRUD.class.php
Line: 209
and:
Code: [Select]
Type of error: Non specificato
Notice: Undefined index: is_first_post
iindex.php?action=quotefast;quote=66659;modify;xml
File: sources/TopicPrefix.integrate.php
Line: 77

Another error: when you edit a prefix, the custom css is not saved.
sorry for my bad english

Re: [ADDON][beta] Topic Prefix

Reply #38
Uploaded a version that should fix all these little bugs.
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON][beta] Topic Prefix

Reply #39
Thanks for watching into this, there is still an old bug that editing a prefix will get a copy of that prefix.
sorry for my bad english

Re: [ADDON][beta] Topic Prefix

Reply #40
O:-)

I forgot it was the prefixes, I thought it was another addon...
Bugs creator.
Features destroyer.
Template killer.


Re: [ADDON][beta] Topic Prefix

Reply #42
@emanuele‍ I know you are busy writing the SEF part for Elkarte, but when you get some free time please have a look at this add-on.

there is still an old bug that editing a prefix will get a copy of that prefix.

Also will be nice to see an option under the Quick moderation so you can apply prefixes from board view to multiple topics. This will be useful for an old forum with some topics.
 
sorry for my bad english

Re: [ADDON][beta] Topic Prefix

Reply #43
Some time ago @vbgamer45‍ made some edits and corrected some bugs on this add-on, @emanuele‍ maybe you want to merge them
sorry for my bad english

Re: [ADDON][beta] Topic Prefix

Reply #44
I started using this add-on but it's still buggy.

The big bug is that a prefix cannot be edited, if you go to topic view and click "Edit" there is no prefix displayed, if I change the prefix I get The database value you're trying to insert does not exist: new_prefix.

X
In the image above there are 2 ways to select a prefix, clicking in prefix list (1) or near a topic title (2)
The first one will get you to /index.php?action=prefix;sa=prefixedtopics;id=2;board=12
The second one to /index.php?action=prefix;sa=prefixedtopics;id=2
Don't know if this is intended...
If you click the first link the breadcrumb looks like this:
X
If I click where the red arrow is I get a database error:
Too few arguments to function TopicPrefix_PxCRUD::count(), 1 passed in sources/subs/TopicPrefixPxCRUD.class.php on line 38 and exactly 2 expected

Second scenario, link /index.php?action=prefix;sa=prefixedtopics;id=2 which I guess displays all topics from all boards
X
if I click the right arrow I get
Too few arguments to function TopicPrefix_PxCRUD::count(), 1 passed in /public/sources/subs/TopicPrefixPxCRUD.class.php on line 38 and exactly 2 expected
sorry for my bad english