Skip to main content
Topic: [ADDON][WIP] In Line Attachments (Read 22012 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: [ADDON][WIP] In Line Attachments

Reply #60
I don't know if this addon will be updated, probably it will be included into the next major release 1.1
Maybe Emanuele or Spuds can give us more information
sorry for my bad english

Re: [ADDON][WIP] In Line Attachments

Reply #61
ILA has been merged into 1.1, so its unlikely that I will update this 1.0 version.  The main missing part from this version was the UI in the posting page, so I may add something but I'm in no rush.

However bugs are welcome to be reported since it this has bugs then of course they exist in 1.1 as well !  I *thinik* @emanuele also added the ability to call a specific attachment by id in 1.1 vs the post "owned" numbered approach here.

Thanks for the translation :D ... yeah no need on the help translation since that ? icon to bring it up is missing in this version ... and the version in 1.1 will be somewhat different.
Be safe, Be kind, Happy Programing

Re: [ADDON][WIP] In Line Attachments

Reply #62
Yep, for the moment I changed it to:
Code: [Select]
[attach]123[/attach]
because is the easiest and allow to add more stuff as parameter.
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON][WIP] In Line Attachments

Reply #63
We will probably want to have a conversion from 1.0 addon to 1.1 core  O:-)
Be safe, Be kind, Happy Programing

Re: [ADDON][WIP] In Line Attachments

Reply #64
Yep, that is one more thing to do... :-\
But I was thinking of pushing it to beta 2 since it's not "really" urgent (because anyway I used a different tag, so the "old" ila can still live on its own).
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON][WIP] In Line Attachments

Reply #65
Just something to track for 1.1 GA .. does not need to be in the betas for sure, but would be nice to have an upgrade (even if its a separate utility that gets run)
Be safe, Be kind, Happy Programing

Re: [ADDON][WIP] In Line Attachments

Reply #66
I'm having some errors in ElkArte log for the attachments inserted with
Code: [Select]
[attachurl=1]
In my case there are two pdf inserted inline, it's an old topic imported from SMF+ILA

Type of error: General
 sprintf(): Too few arguments
File: /../sources/subs/ILA.subs.php
Line: 561

where line 561 is:
Code: [Select]
					</a> (' . $this->_attachment['size'] . ($this->_attachment['is_image'] ? ', ' . $this->_attachment['real_width'] . 'x' . $this->_attachment['real_height'] . ' - ' . sprintf($txt['attach_viewed'], $this->_attachment['downloads']) : ' ' . sprintf($txt['attach_downloaded'] . $this->_attachment['downloads'])) . ')';

I don't know id it worth to fix it now or wait for the 1.1 release ;)
sorry for my bad english

Re: [ADDON][WIP] In Line Attachments

Reply #67
Code: [Select]
sprintf($txt['attach_downloaded'] . $this->_attachment['downloads'])
I assume that . is meant to be a ,.

Re: [ADDON][WIP] In Line Attachments

Reply #68
That looks like the fix to me as well ....
Be safe, Be kind, Happy Programing

Re: [ADDON][WIP] In Line Attachments

Reply #69
Yep, that solved my problem, thank you!
sorry for my bad english

Re: [ADDON][WIP] In Line Attachments

Reply #70
Doesn't seem to work in the preview?

Re: [ADDON][WIP] In Line Attachments

Reply #71
As you can see here thumbnails are a bit blurry. Is there a way to change it? I used the link of the thumbnail in my start page where the picture looks perfectly clear. So it seems ILA does this to the thumbnail?!?

Re: [ADDON][WIP] In Line Attachments

Reply #72
 emanuele sees fine
Quote
Gäste dürfen keine Anhänge anschauen
:P
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON][WIP] In Line Attachments

Reply #73
Oh, sorry. Try again please.

Re: [ADDON][WIP] In Line Attachments

Reply #74
Ok, the main problem is that the size of the thumb is smaller than the size of the image:
http://forum-alternative-antriebe.de/index.php?action=dlattach;topic=5858.0;attach=7555;image
is 150px wide, while the ILA is 250.
I seem to remember ILA thumbnails are created from the normal attachment thumbnails, so... make the normal thumbnails bigger in the admin panel:
admin > forum > attachments and avatars > attachment settings
down in the thumbnail settings use something like 250 or 300.
Then, you'll get bigger "normal" thumbnails, that you will fix adding:
Code: [Select]
.attachment_thumb > a > img {
    max-width: 150px;
}
to your custom.css... I hope. :P
Bugs creator.
Features destroyer.
Template killer.