Skip to main content
Topic: 1.0.2: Quote with link to website - no second quote possible? (Read 1994 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

1.0.2: Quote with link to website - no second quote possible?

When I quote like this:

 [quote=http://hybrid-piloten.de]This is the quote.[/quote]

...I can't make a second quote in the same post.  :o


Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #2
Modify my answer #1 to see the correct bbc. Same error here.


Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #4
Since we are talking about quotes, some more details are necessary. ;)
  • Quick reply or full post page?
  • if quick reply, simple textarea or full editor?
  • if full editor (either quick reply or post page), WYSIWYG or non-WYSIWYG?
Bugs creator.
Features destroyer.
Template killer.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #5
Full post page. Non-WYSIWYG editor.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #6
Okay... I'm slow this morning, now I got what the problem is... :-[
Bugs creator.
Features destroyer.
Template killer.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #7
It's not a bug, it's a feature?  ;)

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #8
Quote from: http://hybrid-piloten.de
This is the quote.

It's not a bug, it's a feature?  ;)
Bugs creator.
Features destroyer.
Template killer.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #9
Oddity... the above doesn't work in preview, but works "somehow" (the url in the first quote is not linked) in a real post.

@Spuds any idea? O:-)

This is the quote.

It's not a bug, it's a feature?  ;)
Bugs creator.
Features destroyer.
Template killer.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #10
The whole thing acts weird.  :o  Try switching between WYSIWYG- and non-WYSIWYG editor. Try to save a post, edit it again, change the bbc (it is now [quote author=http...] instead of [quote=http...] as it was before editing the post). You can get a second quote bbc if the url in the first quote doesn't work with a link to the page. It acts strange and not traceable at first sight.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #11
hmm... at least a pattern is kind of emerging.
Well, we are already late with 1.0.3, we may fix that one as well if it doesn't involve too many oddities...
Bugs creator.
Features destroyer.
Template killer.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #12
Its something to do with the recursive call and the disabled cache values.

In parse, when it working on parsed_equals content quotes, it hits the area that starts with
Quote
// For parsed content, we must recurse to avoid security problems.
which will call parse_bbc to only parse the
Quote
'parsed_tags_allowed' => array('url', 'iurl', 'ftp'),
tags that may be used in an author name.  So thats all cool ...

But that static $disabled gets updated to disable all other tags except those that were in the parsed_tags_allowed, and since its static all points after that seem to be a problem.  You can prove this by commenting out the static $disabled but I think the issue is in the
Quote
// If we are not doing every enabled tag then create a cache for this parsing group.
section.  Could use some more eyes on that.

ETA: I'm thinking that static is useless since we have that mini cache, maybe that should be static $parse_tag_cache = array(); instead?
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #13
Okay, give me a couple of years to try to understand again parse_bbc. LOL
I'll try to have a look at it tomorrow (or the day after).
Bugs creator.
Features destroyer.
Template killer.

Re: 1.0.2: Quote with link to website - no second quote possible?

Reply #14
LOL ... no one will ever understand parse_bbc, its an enigma and must remain so :P

I think the fix is to change static $disabled to static $parse_tag_cache but another set of eyes on is a good thing!
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.