Skip to main content
Topic: Upgrade error (Read 1601 times) previous topic - next topic - Topic derived from ElkArte 1.1 beta 3 - ...
0 Members and 1 Guest are viewing this topic.

Upgrade error

Hi,

1.0.9 upgrade Error
Error retrieving information on step: Adding new columns... (Item: 20)


I tried again has gone first error

new error
Executing: "" (0 of
Notice: Undefined index: total_items in install/TemplateUpgrade.php on line 785
)

Re: Upgrae error

Reply #1
Hi gevv, I moved your post to a topic because it's easier to work on things if each problem is a topic. ;)

So, you are trying to upgrade from 1.0.9 to 1.1 B3, correct?

Could you check in the database if the table elkarte_user_drafts has a column named "is_usersaved"?
Bugs creator.
Features destroyer.
Template killer.

Re: Upgrade error

Reply #2
Hi gevv, I moved your post to a topic because it's easier to work on things if each problem is a topic. ;)

So, you are trying to upgrade from 1.0.9 to 1.1 B3, correct?

Could you check in the database if the table elkarte_user_drafts has a column named "is_usersaved"?

yes 1.0.9 to 1.1 B3  

is_usersaved  ok   all values are 0

Re: Upgrade error

Reply #3
I empty the table elkarte_user_drafts the problem continues

Executing: "" (0 of
Notice: Undefined index: total_items in /home3/elektron/public_html/install/TemplateUpgrade.php on line 785
)

Re: Upgrade error

Reply #4
I empty the table elkarte_user_drafts the problem continues
There was no reason for that. I knew already that empting the table wouldn't fix anything.
I hope you are running the upgrade on a test site, right? (Just because in ay case it's always better to run a test before doing an upgrade with a beta version. ;))

Anyway, check the table elkarte_attachments, the column "mime_type" is a varchar 20 or 255?
Bugs creator.
Features destroyer.
Template killer.

Re: Upgrade error

Reply #5
varchar 255

Re: Upgrade error

Reply #6
Hi,

No update is complete (TemplateUpgrade.php on line 785) , but the forum is working

No such problem

New features works



Do you have a way to go back to the old (1.0.9) version?

Re: Upgrade error

Reply #7
varchar 255
Then the update finished properly... (Actually there would be another step, but it's not so important[1].)
It could be the same problem I that was reported regarding the upgrade fail if there are no steps to perform... It's somehow random and difficult to pinpoint though. :-\
If you use the calendar, open the elkarte_settings table and insert a new entry with "variable" set to "cal_limityear" and value 10
Bugs creator.
Features destroyer.
Template killer.

Re: Upgrade error

Reply #8
Seems like I got bit by this bug too, this time from 1.1.5 to 1.1.6.

PHP 7.2, PHP-FPM and Apache. MariaDB 10.4 on Ubuntu.

Code: [Select]
[Sun Nov 10 07:47:45.958299 2019] [php7:notice] [pid 5830] [client 172.69.63.102:44892] PHP Notice:  Undefined index: total_items in /var/www/html/forum/install/TemplateUpgrade.php on line 785, referer: https://forum.freedomofform.org/install/upgrade.php
[Sun Nov 10 07:47:45.958611 2019] [php7:notice] [pid 5830] [client 172.69.63.102:44892] PHP Notice:  Undefined index: debug_items in /var/www/html/forum/install/TemplateUpgrade.php on line 786, referer: https://forum.freedomofform.org/install/upgrade.php
[Sun Nov 10 07:47:45.958633 2019] [php7:notice] [pid 5830] [client 172.69.63.102:44892] PHP Notice:  Undefined index: debug_items in /var/www/html/forum/install/TemplateUpgrade.php on line 823, referer: https://forum.freedomofform.org/install/upgrade.php
[Sun Nov 10 07:48:49.886009 2019] [php7:notice] [pid 5827] [client 172.69.63.102:58182] PHP Notice:  Undefined index: total_items in /var/www/html/forum/install/TemplateUpgrade.php on line 785, referer: https://forum.freedomofform.org/install/upgrade.php
[Sun Nov 10 07:48:49.886062 2019] [php7:notice] [pid 5827] [client 172.69.63.102:58182] PHP Notice:  Undefined index: debug_items in /var/www/html/forum/install/TemplateUpgrade.php on line 786, referer: https://forum.freedomofform.org/install/upgrade.php?step=1&
[Sun Nov 10 07:48:49.886078 2019] [php7:notice] [pid 5827] [client 172.69.63.102:58182] PHP Notice:  Undefined index: debug_items in /var/www/html/forum/install/TemplateUpgrade.php on line 823, referer: https://forum.freedomofform.org/install/upgrade.php
[Sun Nov 10 08:01:23.255994 2019] [php7:notice] [pid 5827] [client 172.69.63.102:40724] PHP Notice:  Undefined index: total_items in /var/www/html/forum/install/TemplateUpgrade.php on line 785, referer: https://forum.freedomofform.org/install/upgrade.php
[Sun Nov 10 08:01:23.256042 2019] [php7:notice] [pid 5827] [client 172.69.63.102:40724] PHP Notice:  Undefined index: debug_items in /var/www/html/forum/install/TemplateUpgrade.php on line 786, referer: https://forum.freedomofform.org/install/upgrade.php
[Sun Nov 10 08:01:23.256059 2019] [php7:notice] [pid 5827] [client 172.69.63.102:40724] PHP Notice:  Undefined index: debug_items in /var/www/html/forum/install/TemplateUpgrade.php on line 823, referer: https://forum.freedomofform.org/install/upgrade.php

Checked the table and it's set to varchar 255. The calyear database entry is also present, so... not sure what the trigger was this time.

Regards,

Keiro