Skip to main content
Topic: Addon Installation Error (Read 948 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Addon Installation Error

In 1.1 b3, upload, install emulating 1.0, and check everything's ok, click install but then at: /index.php?action=admin;area=packages;sa=install2;package=QRR.v.105.elkarte.ahrasis.com.zip;pid=0
Quote
Connection Problems

Sorry, we were unable to connect to the database. This may be caused by the server being busy. Please try again later.
The addon: http://www.elkarte.net/community/index.php?topic=1822.0

Other addons faced the same error.

Re: Addon Installation Error

Reply #1
I tried again and there are at least five errors:

Quote
Type of error: General
Warning: mysqli_real_escape_string() expects parameter 2 to be string, array given
index.php?action=admin;area=packages;sa=install2;package=QRR.v.105.elkarte.ahrasis.com.zip;pid=0
File: /var/www/clients/client2/web27/web/sources/database/Db-mysql.class.php
Line: 1165

Type of error: General
Warning: max(): When only one parameter is given, it must be an array
index.php?action=admin;area=packages;sa=install2;package=QRR.v.105.elkarte.ahrasis.com.zip;pid=0
File: /var/www/clients/client2/web27/web/sources/database/Db-mysql.class.php
Line: 297

Type of error: General
Warning: array_map(): Argument #2 should be an array
index.php?action=admin;area=packages;sa=install2;package=QRR.v.105.elkarte.ahrasis.com.zip;pid=0
File: /var/www/clients/client2/web27/web/sources/database/Db-mysql.class.php
Line: 294

Type of error: General
Warning: str_split() expects parameter 1 to be string, array given
index.php?action=admin;area=packages;sa=install2;package=QRR.v.105.elkarte.ahrasis.com.zip;pid=0
File: /var/www/clients/client2/web27/web/sources/database/Db-mysql.class.php
Line: 294

Type of error: General
phar "/var/www/clients/client2/web27/web/packages/backups/2016-11-01_before_QRR.tar.gz" exists and must be unlinked prior to conversion
index.php?action=admin;area=packages;sa=install2;package=QRR.v.105.elkarte.ahrasis.com.zip;pid=0

Re: Addon Installation Error

Reply #2
+ topic solved, recent post, bookmaks  1.1 b3 not work
sorry for my bad english

Re: Addon Installation Error

Reply #3
Well, currently I am just looking for fixes to these errors. I cannot test or upgrade addons if they cannot be properly installed. However, I just realized that the addons are installed though they are not listed as installed in Package Manager as their settings are then available in Addons Settings. They are however listed as not found in Integration Hooks and this has been reported earlier I think.


Re: Addon Installation Error

Reply #5
I remember it before but then totally forgot about it. Thank you for pointing it. It is now resolved.