Skip to main content
Topic: xCache Problem (Read 1939 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

xCache Problem

I am not so sure that it is a bug but I posted it in here anyway.

I am using xCache and I set xCache as my level 1 caching accelerator. Then I insert and save my userid and password for it.

The problem is each time I install / remove a package / clear cache  it will open a pop up of Authentication Required.

I don't think it should work that way after userid and password is already supplied but I am not so sure especially when accessing a non-xcache admin page. So I think this could be a bug though it may not be.

The reason is I believe if the same credentials need to supplied again in the pop up, then there is no need to be supplied and saved the same in ElkArte Caching Settings page, as it will be redundant / useless.

Furthermore, if I cancel, I will get a 401 error page but I can refresh that page and get you have send this post message error message. The install / uninstall works even by cancelling. Which is weird.

Moreover, if I use other userid or password like my forum admin credentials, they also work. Which is weird too.

I prefer not to disable admin authentication for xcache though it is possible and never tested it to run in such a way.

I also can use memcache or ACP as an alternative but I still wonder why this happened.

Re: xCache Problem

Reply #1
Furthermore, if I cancel, I will get a 401 error page but I can refresh that page and get you have send this post message error message. The install / uninstall works even by cancelling. Which is weird.
Weird but expected, because the installation is "done" when you click on the "install", not when you see the page with the successful message. If it makes sense. lol
Bugs creator.
Features destroyer.
Template killer.

Re: xCache Problem

Reply #2
Yeah. That's true also. lol

Re: xCache Problem

Reply #3
You should not be getting the xCache authentication popup if you have entered the right uid / password in the cache options page in the ACP, thats the reason we added those fields..  Those values are saved in your Settings.php file.

Also with xCache, be sure you don't have its op cache enabled if you are also using PHP's zend op cache (5.6 or is that 5.5+), that can cause problems. 

Re: xCache Problem

Reply #4
Thanks for the tip. I will test that and report back soonest.

Re: xCache Problem

Reply #5
Were you able to check it? :D
Bugs creator.
Features destroyer.
Template killer.

Re: xCache Problem

Reply #6
Sorry. But I stop using php5 for all my sites except where there is no support for php7. So I did not test xCache further since it is not available for php7.

Re: xCache Problem

Reply #7
xcache requires authentication for clearing the cache, it sees that as an administrative function. Really weird.

Re: xCache Problem

Reply #8
Yup. It is weird especially if you still need to use it. Otherwise, just move on to php7.

Re: xCache Problem

Reply #9
So, is that an issue or just a weird config setting?
Bugs creator.
Features destroyer.
Template killer.

Re: xCache Problem

Reply #10
I think config. xcache is special. :/

Re: xCache Problem

Reply #11
That was an issue to me. But since nobody is porting it to php7, I will not waste my time to try.