Skip to main content
Topic: The Same Old Package Manager Bug (Read 1198 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

The Same Old Package Manager Bug

The same old package manager bug is found in the latest (newly introduced) PackagesFilterIterator.class.php 1.1 RC 1:
Code: [Select]
if (!($current->isDir()) && file_exists($current->getPathname() . '/package-info.xml'))

The error is the same as mentioned before  i.e. file_exists(): open_basedir bla bla bla... and it is definitely not a server fault, again. :P The fix is as mentioned before too i.e. the bracket:
Code: [Select]
if (!($current->isDir() && file_exists($current->getPathname() . '/package-info.xml')))


Re: The Same Old Package Manager Bug

Reply #1
Ha, now I get to blame @emanuele  :D

Re: The Same Old Package Manager Bug

Reply #2
 emanuele blames... heck I guess I can' t find anyone else to blame! LOL
Bugs creator.
Features destroyer.
Template killer.

Re: The Same Old Package Manager Bug

Reply #3
I made a PR for this to ease you guys work over there.

There is another PR for repair_settings.php too, for consideration, though the same still do not work in 1.1, but a reference for future modification is posted in the said PR.