Skip to main content
Topic: ElkArte 1.0.10 - Release announcement (Read 4679 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

ElkArte 1.0.10 - Release announcement

Today, we are pleased to release ElkArte 1.0.10. This is a security release and fixes some security issues that were found and reported in ElkArte. It also contains few other fixes for bugs identified since the release of 1.0.9. As this is a maintenance release, the majority of the updates are focused on bug fixes and increased stability. This is a critical security update and we strongly encourage anyone running any previous version.

This release follows our semantic version (MAJOR.MINOR.PATCH), meaning that third-point (x.x.X) releases should contain backwards-compatible bug fixes and enhancements, so for the most part you will not find new features in this release. Major new features will be reserved for second point versions (x.X.x).

Refer to the release notes on the forum for a complete list of updates.



Patching procedure:
  • go to the page https://github.com/ElkArte/ElkArte/releases/tag/v1.0.10
  • download the file ElkArte_1-0-10_patch.zip to your computer
  • go to your forum: Admin > Main > Package Manager > Upload Package
  • click the button to upload the package
  • locate and select the file you downloaded at point 2
  • click the "upload" button
  • follow the instructions on the screen.

For any question you may have, feel free to ask on the support forum.

Of course you are encouraged to update to this release since it contains a lot of fixes and improvements, thank you for your continued support!
Bugs creator.
Features destroyer.
Template killer.

Re: ElkArte 1.0.10 - Release announcement

Reply #1
And I would like to thank the people that have tested the release: Ahrasis, Jorin, phantom and radu81.
Bugs creator.
Features destroyer.
Template killer.

Re: ElkArte 1.0.10 - Release announcement

Reply #2
I get an error: The package you are trying to download or install is either corrupt or not compatible with this version of the software.

Re: ElkArte 1.0.10 - Release announcement

Reply #3
i got
Quote
Error in package installation
At least one error was encountered during a test installation of this package.
It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently.

This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you have not installed yet, or a package designed for another version of the software.

My theme: Lazyday

My addons:
Code: [Select]
Attachment Image Resize	1.0.2
Disposable Email Check 1.0.0
ElkArte 1.0.10 patch 1.0.0
ElkArte 1.0.6 patch 1.0.0
ElkArte 1.0.7 patch 1.0.0
ElkArte 1.0.8 patch 1.0.0
ElkArte 1.0.9 patch 1.0.0
Global Header and Footer 2.0.1
reCaptcha 1.0.0
Remove Last Edit By 1.0.0
Smush.it! 0.2

Re: ElkArte 1.0.10 - Release announcement

Reply #4
I get an error: The package you are trying to download or install is either corrupt or not compatible with this version of the software.

Same here.

On my support forum I have version 1. 0.8.1 instead of 1.0.9. Please make sure I can install the update there too.

Re: ElkArte 1.0.10 - Release announcement

Reply #5
I get the same non-theme errors as @kucing.[1] I'm on 1.0.9.

Quote from: for SSI.php
Code: [Select]
// Shortcut for the browser cache stale
define('CACHE_STALE', '?109');

Code: [Select]
// Shortcut for the browser cache stale
define('CACHE_STALE', '?1010');

Mine says:
Code: [Select]
// Shortcut for the browser cache stale
define('CACHE_STALE', '?1081');

Quote from: for index.php
Code: [Select]
 * copyright:	2011 Simple Machines (http://www.simplemachines.org)
 * license: BSD, See included LICENSE.TXT for terms and conditions.
 *
 * @version 1.0.9
 *
 */

$forum_version = 'ElkArte 1.0.9';
define('FORUM_VERSION', $forum_version);

// First things first, but not necessarily in that order.
define('ELK', 1);

// Shortcut for the browser cache stale
define('CACHE_STALE', '?109');

if (function_exists('set_magic_quotes_runtime'))
@set_magic_quotes_runtime(0);

Code: [Select]
 * copyright:	2011 Simple Machines (http://www.simplemachines.org)
 * license: BSD, See included LICENSE.TXT for terms and conditions.
 *
 * @version 1.0.10
 *
 */

$forum_version = 'ElkArte 1.0.10';
define('FORUM_VERSION', $forum_version);

// First things first, but not necessarily in that order.
define('ELK', 1);

// Shortcut for the browser cache stale
define('CACHE_STALE', '?1010');

if (function_exists('set_magic_quotes_runtime'))
@set_magic_quotes_runtime(0);

Same issue. Once again, mine says:
Code: [Select]
// Shortcut for the browser cache stale
define('CACHE_STALE', '?1081');
It are the same files, so I assume the actual errors are the same.

Re: ElkArte 1.0.10 - Release announcement

Reply #6
That was the testing version of 1.0.9, if you can, edit your index.php and ssi.php and just install the new one.
Sorry about it...
Bugs creator.
Features destroyer.
Template killer.

Re: ElkArte 1.0.10 - Release announcement

Reply #7
Testing version of 1.0.9? Huh, I don't recall that. In that case the fact that one of my themes says @verson 1.03 while the updater expects 1.06 isn't something specific to my install either? (Other than apparently being the testing version of 1.09).

Re: ElkArte 1.0.10 - Release announcement

Reply #8
That was the testing version of 1.0.9, if you can, edit your index.php and ssi.php and just install the new one.
Sorry about it...

i believe that's for 1.0.8.1? I'm using 1.0.9, if there anything I can do to update safely to 1.0.10?

Re: ElkArte 1.0.10 - Release announcement

Reply #9
Mine shows 1.0.8 but I remember there was an issue with 1.0.8 when it was released which if I remember correctly was why 1.0.9 was released shortly afterwards. I could never install 1.0.9 either. Is there any way to get up to 1.10?

Re: ElkArte 1.0.10 - Release announcement

Reply #10
Here is what I have installed presently and if I try to upload the 1.0.9 patch I get the error message shown below. You can also see by the listing that 1.0.10 does not have an 'Install' link.

Re: ElkArte 1.0.10 - Release announcement

Reply #11
I *think* this is what is going on.  

1) The official 1.0.9 PATCH file that was released, has a couple of version errors in it.  First it uses the ElkArte_1081_patch as the package ID where it should have been ElkArte_109_patch, this gives you the package already exists error.  So if you had installed the 1.0.8.1 test/update version, then you would not be able to download/install the final 1.0.9 patch.

2) Next the official 1.0.9 PATCH still used "1081" instead of "109" in both SSI.php and in index.php  BUT the new 1.0.10 PATCH is looking for that to be 1.0.9 so it creates a couple of update errors.  You would not see those if you started using ElkArte with 1.0.9 as a the FULL package correctly uses 109 in those two areas.  So those errors only effect those that have been using ElkArte since before 1.0.9 :'(

What to do?
1) If you show 1.0.8.1 as installed, I would uninstall that, delete that package file, and then install the official 1.0.9 patch.  1.0.9 has what 1.0.8.1 had and a bit more. 

2) If you do have 1.0.9 installed AND are getting the two update errors, one in SSI.php and one in index.php, that means you should edit those two files and look for
Code: [Select]
define('CACHE_STALE', '?1081');
and change that to
Code: [Select]
define('CACHE_STALE', '?109');
you will find that one in each of those files.  Once done, try the 1.0.10 patch again.

Alternative approach to try ...  If you have 1.0.8.1 or 1.0.9 installed, and don't want to edit files then Uninstall that version (either 1.0.9 or 1.0.8.1 whichever you have).  Download the 1.0.9 version attached to this post, install it, then install 1.0.10.  That should install with no errors. 

Do note that install errors in themes other than the default are not uncommon and can generally be ignored, its up to the theme authors to determine of those changes are appropriate for those themes.

@emanuele should we update the 1.0.10 update to look for 1.0.8.1 as well as 1.0.9 in those two places, given that the 1.0.9 patch file on the release site uses 1.0.8.1.
“The problem is not the problem. The problem is your attitude about the problem. Do you understand?” – Jack Sparrow

Re: ElkArte 1.0.10 - Release announcement

Reply #12
Based on my packages my upgrade path was quite simply 1.0.7 > 1.0.8 > 1.0.9, which I'd assume to quite common.

Quote
Do note that install errors in themes other than the default are not uncommon and can generally be ignored, its up to the theme authors to determine of those changes are appropriate for those themes.
Of course, but it's never complained about a version mismatch in the theme header before (was 1.0.3, expected 1.0.6). Just a funny coincidence I guess. :)

Re: ElkArte 1.0.10 - Release announcement

Reply #13
I missed that it gave an error on a default theme file, do you recall which file?  The official upgrade path that you properly followed  should have only *cough* resulted in two errors due to the cache_stale value. 
“The problem is not the problem. The problem is your attitude about the problem. Do you understand?” – Jack Sparrow

Re: ElkArte 1.0.10 - Release announcement

Reply #14
i did the alternative one (installed the patch2). but the theme error can be ignored? i use lazyday