Skip to main content
Topic: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems (Read 11718 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #30
In theory it should work even with two, but apparently my suspects were right and the current "stable" version is not really able to cope with that and needs to have just one database then.
The development should, but then again it's development and is broken since a while because of some intervention of the Bug Creator. O:-)
Bugs creator.
Features destroyer.
Template killer.

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #31
IIRC the importer asks for SMF database password, I don't have an importer installed to check... I also did the import using the same database.
Glad you solved it  ;)
sorry for my bad english

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #32
@radu81 yep, OI asks for the password like the old converter asked, but I always had the feeling (never actually bothered to check) that this request is used only if the password of the settings is not working, but it doesn't allow you to use two databases with two different users/password, because the php db connection is always one in SMF (and current Elk), it cannot be instantiated multiple times and since the converter follows more or less the original design, it has the same limitations.
Additionally (for the original converter and OI 1.x) certain conversions require the JOIN of tables from both databases (the one to import from and the one to import to), and this doesn't work if the databases do not have the same credentials.
So, basically, you mush have the same user/password pair for both databases, and anyway if you can have only one database is much better (and sure to work).
Bugs creator.
Features destroyer.
Template killer.

 

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #33
That explains why I was not able to migrate using different databases, thanks for pointing out  ;)
sorry for my bad english

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #34
And that reminds me OI should be updated to support 1.1... meh. Always running behind the schedule... :'(

Is the OI update already done? ;)
I want to migrate a SMF 2.0.15 to ElkArte 1.1.3.
ElkArte version: 1.1.6 / Theme: BeSocial / PHP 7.2.7

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #35
I want to migrate a SMF 2.0.15 to ElkArte 1.1.3.
You can go trough elkarte 1.0 and then update to elkarte 1.1.3. It should work, otherwise report the problems.
Maybe this post can be useful https://www.elkarte.net/community/index.php?topic=4868.msg35438#msg35438
sorry for my bad english


Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #37
The 1.0  I'll find here?:
I wasn't very clear, but I was referring to 1.0.x series, so you should use the latest version which is 1.0.10. You can use all the links indicated here, they are still valid:
https://www.elkarte.net/community/index.php?topic=4868.msg35438#msg35438
sorry for my bad english

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #38
I've installed the 1.0.10 and tried to upgrade to the 1.1 , but there's an error now.
I replaced all files and then I ran the install/upgrade.php.

As you can see on the image, two errors are displayed. The line at the top and the "Error retrieving information on step: Remove any old file left and check if the table is empty..." at the bottom.
If I click "continue", step 4 (Database Changes) starts again from the beginning with 1 of 13.

What's wrong there? What should I change in line 546? The permissions for the CommonCode.php and all other files in the install folder I set to 777.
(/www/htdocs/w00xxx/forumxxx/install/CommonCode.php on line 546)
ElkArte version: 1.1.6 / Theme: BeSocial / PHP 7.2.7

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #39
The second row is line 546 of the CommonCode.php.

Code: [Select]
// Clear out the db_last_error file
file_put_contents(TMP_BOARDDIR . '/db_last_error.txt', '0');


EDIT:
I tried it again. Maybe it worked now, but now I have this message:
Maintenance Mode
Okay faithful users ... we're trying to restore an old backup of the database.


I didn't put the forum in maintenance mode during the upgrade. How can I get out of this mode? I've already tried cleaning the browser cache.
.
ElkArte version: 1.1.6 / Theme: BeSocial / PHP 7.2.7

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #40

Does anyone have a suggestion, what I should try now?
ElkArte version: 1.1.6 / Theme: BeSocial / PHP 7.2.7

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #41
There is a setting in your settings.php called maintenance mode, change that to 0 I think it is and it will take it out of that mode.

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #42
The maintenance mode is already set there on 0 ...

$maintenance = 0;
ElkArte version: 1.1.6 / Theme: BeSocial / PHP 7.2.7

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #43
I started again from the beginning and the import into 1.0.10 worked. :)

I'm at step 5 now.
Now I can update to 1.1.1, not to the 1.1 Final before?
And it's always the install.zip for the next versions and not the patch.zip?
ElkArte version: 1.1.6 / Theme: BeSocial / PHP 7.2.7

Re: OpenImporter FAQ ? SMF 2.0.15 to Elkarte problems

Reply #44
Okay, I upgraded now to 1.1.1,
For the next versions, 1.1.2 and 1.1.13, do I need also the install.zips or from now on just the patch,zips ?
ElkArte version: 1.1.6 / Theme: BeSocial / PHP 7.2.7