Skip to main content
Topic: [ADDON] SimpleSEF (Read 15561 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: [ADDON] SimpleSEF

Reply #30
Sorry for being so late, I've missed the topic... :-[
I'm really sorry.

If I'm not completely dumb (and I may actually be), to "quickly" uninstall the addon, just delete the file SimpleSEF.php from the sources directory. Once this is gone, the addon will not do anything any more.

About the error, being this late I didn't see the mess, so I'm not able to tell what could have happened...
If you can describe it I can try to guess, but guessing is not always the best thing to do. As we learned in this very case. :(
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON] SimpleSEF

Reply #31
Sorry for being so late, I've missed the topic... :-[
I'm really sorry.

If I'm not completely dumb (and I may actually be), to "quickly" uninstall the addon, just delete the file SimpleSEF.php from the sources directory. Once this is gone, the addon will not do anything any more.

About the error, being this late I didn't see the mess, so I'm not able to tell what could have happened...
If you can describe it I can try to guess, but guessing is not always the best thing to do. As we learned in this very case. :(

I'm not sure what exactly happened here, but basically, what I did was to download SimpleSEF directly to the package directory. Uncompress it, as usual.

Then I went to the forum's admin center to install the package. After that, it redirects me to where I can actually manage the settings of the package in question. As soon as I enable it, no matter what options I pick, it immediately breaks as soon as I press apply.

Would you like access to the forum to try seeing this for yourself? The only way to get back into it is to go back into phpmyadmin and disable the mod's status by setting its status to 0 for enable/disable.

Re: [ADDON] SimpleSEF

Reply #32
As soon as I enable it, no matter what options I pick, it immediately breaks as soon as I press apply.
The problem here is define what "breaks" means. Really.
With htaccess and buffer rewrite around, breaks could mean literally any thing. ;)
Was giving a particular error? Was showing something specific? Any other detail?
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON] SimpleSEF

Reply #33
As soon as I enable it, no matter what options I pick, it immediately breaks as soon as I press apply.
The problem here is define what "breaks" means. Really.
With htaccess and buffer rewrite around, breaks could mean literally any thing. ;)
Was giving a particular error? Was showing something specific? Any other detail?

I tried it both with and without .htaccess. I tried the .htaccess code you specified prior to my installing SimpleSEF. This is on an cPanel server, so I know .htaccess rules work. However, I've been having issues troubleshooting it... because it doesn't show up in the server's httpd logs at all.

I'm leaving SimpleSEF enabled for now so you can see for yourself the result of https://lysharia.com

Hmm. Wonder if SimplePortal being installed causes issues?

Re: [ADDON] SimpleSEF

Reply #34
For the time being, I cannot see your forum at all. I think you can just rename the .htaccess to htaccess.txt and delete SimpleSEF.php from the sources directory as suggested by @emanuele .

Re: [ADDON] SimpleSEF

Reply #35
For the time being, I cannot see your forum at all. I think you can just rename the .htaccess to htaccess.txt and delete SimpleSEF.php from the sources directory as suggested by @emanuele .

This is what happens when I enable SimpleSEF. Every single time. However, I did notice an interesting thing... this doesn't happen if I comment out this bit of code in .htaccess:

Quote
#RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Edit: Nope, looks like it happens even if I leave it commented out or leave it uncommented.

Re: [ADDON] SimpleSEF

Reply #36
Ok, now I have a better idea of what is going on.
Just for the record, next time asimple screenshot is probably enough. ;D

It's a buffer-rewrite problem, I'll see if I can find out how to fix it.
It looks like a regexp is failing pretty bad.
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON] SimpleSEF

Reply #37
Ok, now I have a better idea of what is going on.
Just for the record, next time asimple screenshot is probably enough. ;D

It's a buffer-rewrite problem, I'll see if I can find out how to fix it.
It looks like a regexp is failing pretty bad.

It's okay. I don't mind leaving it on like that... it's not like it's a constantly-used site. >_>

But thanks for checking into it. :) Disabling SimpleSEF, now.


Re: [ADDON] SimpleSEF

Reply #39
One day I hope so. :P
I'm pretty bad with regular expressions! xD
Bugs creator.
Features destroyer.
Template killer.

Re: [ADDON] SimpleSEF

Reply #40
One day I hope so. :P
I'm pretty bad with regular expressions! xD

So we see... :P

I think I will go ahead and try fixing it. It's just the regular expressions that's the issue, correct?

Re: [ADDON] SimpleSEF

Reply #41
Hmm, using http://www.devbug.co.uk for PHP code analysis returns the following:

Quote
Line 128: Eval Injection in 'preg_replace' via '$_GET'
Line 128: Eval Injection in 'preg_replace' via '$_SERVER'
Line 176: Header Injection in 'header' via '$_SERVER'

However, it doesn't catch the undefined objects that my forum was logging errors for that I posted.

Re: [ADDON] SimpleSEF

Reply #42
Any update on this addon? I tried but doesn't seem to convert the url

Re: [ADDON] SimpleSEF

Reply #43
It would be great, if you help me with this Addon @emanuele

1) Where to put the .htaccess file
2) SimpleSEF is enabled and i get these help file

If you have an Apache webserver, or one that uses .htaccess and has mod_rewrite functionality, you need a .htaccess file in your main SMF directory with the following: Code: RewriteEngine On
# Uncomment the following line if its not working right
# RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

3) I pasted the .htaccess code and placed the file in the root folder. But the url hasn't changed. Am i doing something wrong.

4) I get this error, "The page you requested could not be found. Please contact the site administrator if you believe you have reached this page in error". So my host doesn't support it?

Re: [ADDON] SimpleSEF

Reply #44
Sorry, but I completely lost this topic (as you may have noticed I'm quite busy until the end of the month, from March I'll be likely free again and I'll just have to catch up on all I left behind).

Unfortunately, I picked up the "wrong addon" to take care of since I'm terribly bad with regex *and* htaccess rewrites, so it will take some time.
On the other hand, I was wondering: since the addon is MPL, what would you think about distributing it with 1.1? O:-)
Yeah, I know, more delay...that's why I don't know what to do... :-\
Bugs creator.
Features destroyer.
Template killer.