Skip to main content
Topic: Probleme beim Installieren von Addons (Read 211 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Probleme beim Installieren von Addons

Hallo!

Ich habe einTestforum für die 1.1.3 angelegt und in dem ein paar Addons installiert.
Bei einigen kam die Fehlermeldung, dass das Packages-Verzeichnis nicht beschreibbar sei, obwohl es auf 777 steht. Habe im Verzeichnis dann einen temp-Ordner angelegt und danach ging es.

Nun will ich dieselben Addons in meinem neuen Hauptforum installieren und jetzt wollen einige von denen einfach nicht. Trotz des "Tricks" mit der temp und Versuchen, die Besitzrechte auf PHP-User umzustellen.
Wenn ich nach dem Hochladen der zip-Dateien diese installieren will, kommt diese Fehlermeldung:

Fehler im Paket "Installation"
Es wurde mindestens ein Fehler beim Test installation der Installation des Paketes gefunden. Es wird dringend empfohlen, nicht mit der Installation fortzufahren, wenn du dich nicht ausreichend auskennst oder keine aktuelle Sicherung gemacht hast. Diese Fehlermeldung kann auf einen Konflikt zwischen dem zu installierenden und einem existierenden Paket hinweisen, auf einen Fehler im Paket selbst oder auf eine Inkompatibilität zwischen dem Paket und der Version des Forums.

Beschreibung:
Änderungs-Ausführungsfehler
  (steht mal nur bei einem Punkt oder auch mal bei mehreren)

Woran kann das liegen und was könnte ich jetzt mal versuchen?

Installieren ließen sich nur die Addons, die bisher eigentlich nur mit der 1.0.x funktionieren und wo es beim Installieren z.B. hieß:  "Installiere mit Emulation: 1.0.4".  Die Addons dagegen, die jetzt auch 1.1.x-fähig sein sollen, bekomme ich nun einfach nicht zum Laufen. Momentan sind es diese:

- Fancy Box
- Simple Audio Video Embedder
- HTML5 Video Audio Embedder
- Rename Topic
.
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Probleme beim Installieren von Addons

Reply #1
Wie ich eben erst gesehen habe, hatte ich auf dem Server im Packages-Verzeichnis versehentlich die "ElkArte_v1-1-3_patch.zip" gelöscht (beim Löschen von Addon-ZIP's, deren Installation fehlgeschlagen war). :o
Habe die "ElkArte_v1-1-3_patch.zip" jetzt einfach wieder hochgeladen. Als Forumsversion wird weiterhin 1.1.3 angezeigt und im Paketmanager heißt es bei beim Patch der 1.1.3 auch wieder "installiert".
Kann das kurzfristige Löschen vielleicht nun das Installieren der Addons abblocken??? Das klappt nämlich weiterhin nicht.
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Probleme beim Installieren von Addons

Reply #2
ich bekomme die auch nicht installiert und habe auch gleich die 1.1.5 als neues Forum insatlliert.

Re: Probleme beim Installieren von Addons

Reply #3
Bei mir funktioniert das Installieren von Addons nun immer. Warum es, wie jetzt bei dir, manchmal aber doch wieder nicht geht, weiß ich nicht. Vor allem ist es komisch, dass sich manche installieren lassen und manch andere wiederum nicht.
Vier meiner Addons sind noch auf dem Stand der ElkArte-Version 1.0.x . Sie haben sich unter 1.1.5 trotzdem installieren lassen und laufen auch fehlerfrei. Das ist wohl aber nicht bei allen "veralteten" Addons der Fall.
Vor dem Update von 1.1.4 auf 1.1.5 habe ich alle Addons deinstalliert und sie nach dem Update neu installiert. Bei allen hat das prima und ohne Probleme geflutscht.
Klappt bei dir das Installieren nur mit bestimmten Addons nicht oder geht es bei gar keinem?

Diese Addons benutze ich zurzeit:
Bookmarks
Elkarte Stop Spammer
Fancy Box 4 ElkArte
HTML5 Video Audio BBC
OEmbed Support
Optimus
Rename Topic
Simple Audio Video Embedder
Spoiler Modern
Topic Author
Ultimate Menu
Users online today
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Probleme beim Installieren von Addons

Reply #4
ich bekomme manchmal den Fehler : "copy(/var/www/elkarte/themes/default/css/portal.css): failed to open stream: Permission denied"
Keine Ahnung warum?

Offensichtlich liegt es daran, dass die Rechte (chmod) nicht von elkarte durchgeführt werden können. Keine Ahnung warum, obwohl ich eine funktionierende Testverbindung per FTP herstellen kann.

Re: Probleme beim Installieren von Addons

Reply #5
Mit Fehlern kenne ich mich leider nicht aus. Wenn bei mir mal welche auftauchen, muss ich selber immer hier im Forum nach Hilfe suchen... :-[

Frage am besten wegen deines Fehlers mal im Addons-Board im Thread/Thema zu dem entsprechenden Portal-Addon nach.
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Probleme beim Installieren von Addons

Reply #6
Habe es jetzt hinbekommen. Nur wie stellt man die Uhrzeit auf 24h um.... Ich habe die einstellung noch nicht gefunden

Re: Probleme beim Installieren von Addons

Reply #7
Gehe hier hin:  Administrations-Center -> Funktionen & Optionen -> Funktionen

Dort findest du die Zeile "Voreingestelltes Zeitformat". Wenn du vorne dran auf das Fragezeichen klickst, wird dir eine Liste mit Kombinationen angezeigt. Da kannst du welche aussuchen und dann in deiner Wunschreihenfolge in das Eingabefeld eintragen.
Ich habe es dort so stehen:  %d. %b %Y, %H:%M Uhr
Hinten dran ist einfach noch das Wort "Uhr" gesetzt. Im Forum steht dann bei allen Beiträgen als Uhrzeit z.B.  18. Aug 2018, 15:45 Uhr .
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Probleme beim Installieren von Addons

Reply #8
Die einfachsten Dinge liegen so nah, bloß man kommt nicht drauf. Wenn man in den Einstellungen auf das Fragezeichen klickt, dann sieht man auch was man nehmen muss.

Re: Probleme beim Installieren von Addons

Reply #9
 ;)  Wenn man neu dabei ist, übersieht man schnell mal was. Schön, dass es jetzt aber geklappt hat.
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7

Re: Probleme beim Installieren von Addons

Reply #10
Danke, dass du dich ein bißchen hier kümmerst, @Mrs. Chaos. Mir fehlt leider momentan total die Zeit.  :-[

Re: Probleme beim Installieren von Addons

Reply #11
Hallo @Jorin, ich hab ja selber schon viele Fragen hier im Forum gestellt und immer hilfreiche Antworten bekommen. Da helfe ich nun auch gerne mal anderen, soweit ich das Wissen dazu habe. :)
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7