Skip to main content
Topic: Custom Message icon not visible (Read 872 times) previous topic - next topic - Topic derived from Re: a new entry in th...
0 Members and 1 Guest are viewing this topic.

Custom Message icon not visible

I add a new icon 18x18 camera.png in /themes/default/images/post. I can set this new icon with a new entry Video in the menu and i can choose this Message Icon when i write a post... but after the post is submited the icon is not display in my replie ! All the others icons works fine but there are all the default icons.

Not sure I understand well, the icon is visible when you start a new topic but not on replies? Could be a bug, I'll try to replicate this on a test forum.

I'd say it's a bug and here is what I noticed: 
- I created a new custom icon called mobile (I used a copy of one existing image file renaming it to mobile.png)
X
- when opening a new topic or posting a reply you can choose the custom icon from dropdown but it is not displayed in topic view. If you try to edit the post using the complete editor (More -> Edit) you will get the same result, custom icon displayed in editor but not visible in topic view
X X
- strange is if I use the Quick Edit option I see the default icon instead of my custom icon. Changing the icon from Quick edit works and icon is visible after edit.
X X
sorry for my bad english

Re: Custom Message icon not visible

Reply #1
Hi,
You are right : it's exactly the problem.
Philippe

EDIT1
The probem is for a new topic or a reply. An example :


Philippe

Re: Custom Message icon not visible

Reply #2
This appears to be caused by MessageTopicIcons.class.php not loading in the custom icons, it only loads in the known default ones.  I have a fix proposal that I'll place on github for review.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.


Re: Custom Message icon not visible

Reply #4
Hi Spuds,
Thank you to try to solve this bug.
I don't understand what to do with the files in github ! I must just take these files and replace the same on a test forum ?
Philippe

Re: Custom Message icon not visible

Reply #5
If you want to test, you would take this version of MessageTopicIcons.class.php and replace sources/subs/MessageTopicIcons.class.php

You would then have to edit the file sources/subs/TopicUtil.class.php

Code: (find) [Select]
		$icon_sources = new MessageTopicIcons(!empty($modSettings['messageIconChecks_enable']), $settings['theme_dir']);
Code: (replace) [Select]
		$icon_sources = new MessageTopicIcons(!empty($modSettings['messageIconChecks_enable']), $settings['theme_dir'], $topics_info);

But not this is just a proposal at this point, there may be a better fix ;)
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Custom Message icon not visible

Reply #6
This issue should be tracked so hopefully it can be fixed before 1.1.4 is released.

Re: Custom Message icon not visible

Reply #7
But not this is just a proposal at this point, there may be a better fix ;)
Hi Spuds,
Your proposal is in test but nothing change : the new icon is stil not display after submit, but if i edit my message the icon is here.
Philippe

Re: Custom Message icon not visible

Reply #8
What I did fixed the icon not displaying correctly in the topic listing.   Unfortunately is a different error than the one being discussed here!

I've been looking into the error discussed above, and while doing that, I've found yet another issue with them!  Hope to have a proper fix for all of these issues soon.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Custom Message icon not visible

Reply #9
Thank you Spuds ! :D
Philippe

Re: Custom Message icon not visible

Reply #10
Use this file and replace sources/subs/MessageTopicIcons.class.php

That should fix one more of the issues ...
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Custom Message icon not visible

Reply #11
A great thank you Spuds !
It works fine.
I would to clic to a like button but no Like button is display ! I can see somme Likes made by other users but buttons for me.
Philippe